0

I have encountered an issue with a 7" waveshare touch screen I am using in a project. the screen is calibrated perfectly and when tapping on items like folders and files, the folders and files will select, but single tapping, double tapping etc does not open the file or folder.

However, when tapping on taskbar items like menu, terminal etc they will open and run as usual. Additionally, the project i am working on uses a numerical keypad displayed on the touch screen, tapping the numbers works as it should, so it appears that this issue has only affected files and folders.

Case is I have a folder on my desktop with a python script inside the folder. I can tap on the folder and it will highlight as though it is selected, but on further tapping, the file does not open.

using a mouse via USB works as it should.

I have added the required lines to the config.txt file on boot: dtoverlay=vc4-kms-v3d dtoverlay=vc4-kms-dsi-7inch

I have also tried without these lines added to the config file. As an FYI I have 3 of the exact same devices set up, all have the same issue. This is running on stock standard Raspbian Bookwork

Thanks in advance for you help!

1
  • please add a clear, answerable question to your post
    – jsotola
    Commented Dec 13, 2023 at 2:35

1 Answer 1

0

Not too sure if you have fixed this problem already but i found the solution!

Open up the file explorer on your taskbar and then tap on the edit tab ----> choose preferences

In the general tab tick the box that says "open files with single click"

That should have solved your issues. Hope you have a good day :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.