4

I installed latest Raspberry PI os and it has a default browser (Epiphany).

I want to run my simple html5 webpage having a video, but browser is displaying only video controls and do not stream video.

I use html5test.com for checking the supporting videos format, (webm) and it is supporting my uploaded video.

Any suggestion or idea why Epiphany browser is not running my video??

  • Have you tried another browser? Midori is already installed, and chromium (an open source version of chrome) can be installed with sudo apt-get install chromium-browser. – Steve Robillard Feb 20 '15 at 10:26
3

Your simplest solution would be to upload your video to youtube, maybe run your webpage in a window with a live link to the youtube address then follow my previously suggested workaround for displaying Youtube videos:

After hours of seeking solutions to play YOUTUBE videos, I have found the solution in the Epiphany Browser. Installs with the following 3 commands:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install epiphany-browser

BUT THEN:

You must reboot, then (AGAIN!):

sudo apt-get update

Then navigate to www.youtube.com/html5 check off use HTML5 player. In the RPi's operating system's sound icon, right click and check "Analog" then plug in headphones or speakers into the Pi jack (HDMI setting here, did not provide adequate quality)

I have experienced most youtube videos to play well with these steps, the exceptions I've found are some music videos. All videos seem to retain the white on red Youtube play button throughout the video, smack in the center of the screen throughout... If the video will play, the play button will stop blinking within 30 seconds, right clicking, then reload will work, after another video selection has been made. Pause will not work; & any mouse movements after the video has started affects the sound...if you can put up with these inconveniences, welcome to Youtube on a slice of Pi !

1

It could be that the gpu doesn't have enough memory to work with.

In the terminal, try: "sudo raspi-config" -> "Advanced Options" -> "Memory Split" and set an appropriate value (like 128).

  • Interesting idea. Why do you think it could be lack of memory? – Bex Jan 20 '15 at 8:19
  • @kWicki88 I change the memory but still its not working even I changed value to 128 and then to 256 but still its not working – Noman Uddin Jan 20 '15 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.