1

I'm using BlueZ and a USB Bluetooth adapter to provide ethernet to a Pi. Using this method here: Look Ma, no Wires! Raspberry Pi Bluetooth tethering

I'm building a low power project using a Model A which has no ethernet and only one USB port. The immediate problem I found was that I can't connect a USB keyboard and the Bluetooth adapter at the same time to set it up. So what I did was set it all up on a Model B (ssh via the Ethernet port). I set the bluetooth ethernet connection to start on boot. All systems go. I then transferred the SD card and the Bluetooth device (ie. the same MAC) to the Model A, crossed my fingers and... of course it didn't work.

It's not the ethernet bridge which is the problem, it just can't seem to see the USB devices at all.

I added sudo bluez-test-device list to the start script. This lists the paired devices. If no devices are paired it simply returns nothing. But on the Model A it fails with:

dbus.exceptions.DBusException: org.bluez.Error.NoSuchAdapter: No such adapter 

I am thinking that installing BlueZ sets up a configuration specific to the USB chipset on the device. I can boot the same SD card in different Model Bs indicating the USB doesn't have any kind of serial or MAC like identifier. So there must be some other kind of difference between the USB port between Model A and B.

I'm fairly sure the USB port itself is OK because it works fine with a USB keyboard.

I have ordered a serial link cable so that I can I set up BlueZ directly on the Model A, but until that arrives I thought I would see if anyone had any ideas. I also tried using a USB hub, so I can also connect a keyboard but the hub I have doesn't want to work.

  • "The immediate problem I found was that I can't connect a USB keyboard and the Bluetooth adapter at the same time to set it up" - Could you tell us why not? – user22948 Feb 6 '15 at 9:19
  • There is only 1 USB port on a Model A. – slipperyseal Feb 6 '15 at 9:36
  • 1
    Just now I saw your USB hub is not working... – user22948 Feb 6 '15 at 9:40
  • I guess i'll try to find another hub. While waiting for the serial cable to arrive. Just thought I would put out the question incase anyone had any ideas. – slipperyseal Feb 6 '15 at 9:42
0

I bought a different dongle and it worked fine. I was originally using an Asus BT211, which apparently requires firmware-atheros drivers installed. Even once installed, it seemed to only work in the Model B, not the Model A.

I did some tests where i booted both the Model A and Model B without the dongle attached, and the Model B reports the NoSuchAdapter error, just as the Model A wether the dongle is attached or not.

The new dongle is a Targus Bluetooth 4.0 Dual-Mode Micro USB Adapter - ACB75.

I connected to the Model B with a keyboard, expecting to have to reconfigure it. On boot, it wanted to pair with my MacBook, which i accepted, and the DHCP connected. I transferred the SD and the Targus over to the Model A and it started fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.