0

I want to use emacs and magit on my raspberrypi. Magit requires git 1.9.4 or above. I tried this :

https://stackoverflow.com/questions/25088554/how-to-install-git-1-8-or-above-on-debian-wheezy

But the backport goes to git 1.9.1...

Any ideas ?

3

You can build from source by executing the followings :

sudo apt-get install gettext
wget https://www.kernel.org/pub/software/scm/git/git-1.9.4.tar.xz
tar -xvf git-1.9.4.tar.xz   #or tar -xvf git-1*

If you check the site https://www.kernel.org/pub/software/scm/git/ you can see many other distributions and you can choose any of them.

cd git-1.9.4/               #or cd git-*
./configure --prefix=/usr --with-gitconfig=/etc/gitconfig
make
sudo make install

You can check your version of git by :

git --version

Also check this topic : https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=103152

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.