18

I'm using my raspberry pi displayed on a tv through HDMI. It boots up into the terminal and is fine, however, when I leave it for a few minutes, the display goes to sleep.

I'm using an application called conspy to control the console from another computer, but the display does not wake once I start typing (I can still ssh and everything else).

Is there a command that will wake the display or just prevent it from sleeping? I'm not using the GUI, just the console it boots into.

Edit: I sometimes use the standard video output as well, so a fix for either hdmi or video will be appreciated.

  • 1
    Make sure it's the Pi actually turning the TV blank, and not the TV's built-in sleep timer. :) – tlhIngan May 29 '16 at 18:18
12

You could try

you@yourpi:~$ setterm -powersave off -blank

This should prevent the screen from sleeping for the current session. Put it in your .bashrc to make it permenant.

| improve this answer | |
  • 2
    Returns "cannot (un)set powersave mode", even when I try sudo – Will Cobb Nov 25 '12 at 1:46
  • Is X running? If so, end it and retry. – xereeto Nov 25 '12 at 1:52
  • 4
    Even better, add consoleblank=0 to the kernel command-line. – xereeto Nov 25 '12 at 2:00
  • 1
    I rebooted and it accepted it (setterm -powersave off -blank). My screen saver hasn't activated since. Thank you. – Will Cobb Nov 25 '12 at 2:26
  • 4
    I get an error: setterm: terminal xterm-256color does not support --blank setterm: cannot (un)set powersave mode: Inappropriate ioctl for device :( – mgPePe Jan 24 '16 at 20:29
0

As per this thread, you can edit /boot/cmdline.txt, appending consoleblank=0.

This changes the kernel parameter. (This is also mentioned in the comments to the other answer, but these are explicit instructions on how to set it.)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.