2

I have two raspberry pi 2 boards. I have wrote raspbian wheezy image on 8GB card using win32DiskImager. But whenever I run my board, nothing appear on the desktop connected (hdmi to VGA converter used)

Tried by replacing sd card or pi board also, rewrite image several times. Checked for solid +5V supply by CRO. Nothing shows up on desktop. Downloaded image again & tried it also. Not working

However I have a old SPI based TFT image, when i write this image & boot pi.; screen appears. But since its a TFT image, on scrren I see Pi booting up, but then it stops on message "fps = 50 ****". something like that. Since pi will now show data on TFT. I don't have TFT now, so I cannot see data.

Whenever I use TFt image, I see something on screen, that means pi is working & all HDMi & desktop is oK. But as soon as I write wheezy image, nothing appears.

  • are you sure that the HDMI to VGA adapter is working. Can you try using a regular HDMI cable to a monitor or TV or barring that the composite video output? Also have you tried Jesse? – Steve Robillard Dec 3 '15 at 10:42
  • try to access using Putty and xming server visit – AKASH Dec 3 '15 at 11:31
  • You can try accessing the raspberry pi over serial port – tejas Dec 3 '15 at 15:47
  • Have you tried installing the OS to the SD card using NOOBS? – DolbyOver Apr 3 '16 at 11:56
1

First of all I must suggest you to use raspbian buster. Then I think you have a problem with your HDMI cable ,same as me. Assume you are using latest release of raspberry pi then you don't have to play with /boot/config.txt. Change the cable and OS both.

0

I have loaded Jessie today & its working. Now I can desktop screen. Strange I rewrote the card with wheezy image(fresh downloaded from internet) & its not working again. Same problem. Loading jessie again works fine.

0

It's because the recommended build for RPi2 is Jessie, not wheezy.

-1

Two days ago I started using jessie and had same problem like you do but I did not check it with SPI Display.

I did check config.txt and used the last setting that I used when the OS was still wheezy. It works.

I remember I followed this post https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=5851&p=77547#p77547. you need to set up the mode and group as in this : # uncomment to force a specific HDMI mode (this will force VGA) hdmi_group=2 hdmi_mode=39 # uncomment to force a HDMI mode rather than DVI. This can make audio work in # DMT (computer monitor) modes hdmi_drive=2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.