1

This question already has an answer here:

I am trying to connect the Raspberry pi 2 running on Raspbian to my win7 laptop via ethernet. After the connections are done, when I point the mouse on the network icon, I am getting a message, 'eth0: configured '. But when I try opening a browser, I am not able to access the net. When I open chromium, I am getting a message about DNS lookup failing.

Please help!!

marked as duplicate by Ghanima, goldilocks Dec 18 '15 at 12:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • If you are connecting this directly to Windows this is normal. Configuring Windows is NOT a Pi question. – Milliways Dec 18 '15 at 7:07
  • Have a look here: raspberrypi.stackexchange.com/questions/11684/… Also as Milliways already suggested the question is not specific to the Pi. You're looking for the bridging of networks (namely WiFi - connected to your cable modem/home router) and ethernet to the Pi) on your Win7 laptop. – Ghanima Dec 18 '15 at 10:43
2

Using Google DNS is a sound advice, but you shouldn't set a nameserver manually in /etc/resolv.conf. Instead, consider right-clicking on network connection icon (I assume you're using NetworkManager), select "Edit Connections" and manually add "8.8.8.8" as a name server for your connection.

Alternatively, you can configure dhclient to use Google DNS for all DHCP-configured connections, by adding the following line to /etc/dhcp/dhclient.conf

supersede domain-name-servers 8.8.8.8;

If Google DNS is not working for you, check connection properties in Windows to find out which DNS server it is using, and configure your RPi to use the same, as explained above.

  • I don't think NM is used on Raspbian by default (if it's Raspbian). I might be wrong. – goldilocks Dec 18 '15 at 12:55
  • I don't know that too, but all GUI connection managers I know have a way to specify a DNS server. – Dmitry Grigoryev Dec 18 '15 at 13:04
1

Add nameserver 8.8.8.8 or your preferred dns server to /etc/resolv.conf

  • 2
    With respect, you post a number of answers without finding out what the actual problem is. This is not, per se, wrong, but probably irrelevant to anyone using default setup on recent Raspbian. I have no /etc/resolve.conf on my Raspbain Jessie. It is /etc/resolv.conf and is normally set automatically by dhcpcd. – Milliways Dec 18 '15 at 7:15
  • You missed my point. You did not find out what the actual problem is. This is a common problem for new users (and young engineers). The question is vague, and providing an answer to one possible interpretation rarely helpful. – Milliways Dec 18 '15 at 22:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.