2

When I reboot my pi the isc-dhcp-server fails to start

root@r2d2:/home/pi# systemctl status  isc-dhcp-server.service
● isc-dhcp-server.service - LSB: DHCP server
   Loaded: loaded (/etc/init.d/isc-dhcp-server)
   Active: failed (Result: exit-code) since Thu 2016-05-19 17:00:02 BST; 55s ago
  Process: 529 ExecStart=/etc/init.d/isc-dhcp-server start (code=exited, status=1/FAILURE)

May 19 17:00:00 r2d2 dhcpd[592]:
May 19 17:00:00 r2d2 dhcpd[592]: No subnet declaration for eth0 (no IPv4 addresses).
May 19 17:00:00 r2d2 dhcpd[592]: ** Ignoring requests on eth0.  If this is not what
May 19 17:00:00 r2d2 dhcpd[592]: you want, please write a subnet declaration
May 19 17:00:00 r2d2 dhcpd[592]: in your dhcpd.conf file for the network segment
May 19 17:00:02 r2d2 isc-dhcp-server[529]: Starting ISC DHCP server: dhcpdcheck syslog for diagnostics. ... failed!
May 19 17:00:02 r2d2 isc-dhcp-server[529]: failed!
May 19 17:00:02 r2d2 systemd[1]: isc-dhcp-server.service: control process exited, code=exited status=1
May 19 17:00:02 r2d2 systemd[1]: Failed to start LSB: DHCP server.
May 19 17:00:02 r2d2 systemd[1]: Unit isc-dhcp-server.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.

when I restart it from the shell it seems fine

root@r2d2:/home/pi# systemctl restart isc-dhcp-server
root@r2d2:/home/pi# systemctl status  isc-dhcp-server
● isc-dhcp-server.service - LSB: DHCP server
   Loaded: loaded (/etc/init.d/isc-dhcp-server)
   Active: active (running) since Thu 2016-05-19 17:03:18 BST; 11s ago
  Process: 781 ExecStart=/etc/init.d/isc-dhcp-server start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/isc-dhcp-server.service
           └─790 /usr/sbin/dhcpd -q -cf /etc/dhcp/dhcpd.conf -pf /var/run/dhcpd.pid eth0

May 19 17:03:16 r2d2 dhcpd[789]: Wrote 0 deleted host decls to leases file.
May 19 17:03:16 r2d2 dhcpd[789]: Wrote 0 new dynamic host decls to leases file.
May 19 17:03:16 r2d2 dhcpd[789]: Wrote 0 leases to leases file.
May 19 17:03:16 r2d2 dhcpd[790]: Server starting service.
May 19 17:03:18 r2d2 isc-dhcp-server[781]: Starting ISC DHCP server: dhcpd.
May 19 17:03:18 r2d2 systemd[1]: Started LSB: DHCP server.

This has been happening since I re-imaged the pi with the latest distro

RASPBIAN JESSIE
Full desktop image based on Debian Jessie
Version:May 2016
Release date:2016-05-10
Kernel version:4.4

I think this may relate to the new dhcpcd (dhcp client daemon) config, but I do not know exactly how to resolve it.

Does anyone know the cause? Are there any workarounds?

1

Look at this link, under the "Not So Fast" section. Maybe the Fast boot mode, which doesn't wait for network connectivity, is affecting something?

http://blog.dantup.com/2016/04/setting-up-raspberry-pi-raspbian-jessie-to-send-email/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.