3

I've read so many issues similar to mine, but haven't found any clear answers, hopefully someone will know.

I have a DS18b20 installed on pin 4 with a 4.7k resistor, all settings appear to be correct and it has wrote to the database many times(View here). The issue is everything will be working fine, then it stops reading the data from the probe. When this occurs the usual files in /sys/bus/w1/devices/ that read "28-" are missing and replaced with 1-3 dynamic files(meaning they constantly change) labeled as "00-0". Below is a list of current files in the directory, which will change very shortly automatically or if I attempt to read one:

00-028000000000  00-fc8000000000  w1_bus_master1

I was able to correct this problem by disconnecting the wiring and rebooting the pi however this fix is only temporary, the longest read time being 3 days so far..

Does anyone know what could be causing this issue? I have tried all troubleshooting I could find via google search and stackexchange, still no dice.

A potential fix could be a hard reset for the 5v out that simulates disconnecting the wire, as far as I know this can only be done by actually removing the wire.. It's possible it could be the breadboard I'm using, but I have tested and checked it 50 times; it doesn't get handled or bumped, so it's weird that nothing physically changes when this occurs. I also use this remotely to monitor the system so would like to explore the software side further in case there's something I can do while away.

1

I've had this problem in the past and it was related to the power supplied for the DS18B20s (in parasitic mode).

I'm the problem is now resolved, but I'm not sure specifically what fixed it. In my /boot/config.txt I have:

dtoverlay=w1-gpio,gpiopin=4,pullup=on 

and in /etc/modules

w1-therm strong_pullup=1

Again, not sure specifically what fixed it, but hopefully this helps.

1

I faced the same issue. Sensors disappeared randomly. I spent two weeks checking connection and replacing sensors with new ones with our any results. Finally, I changed the power supply and works for a week without any issues.

0

After having had the same problem, I found out what caused it. I measured the voltage over the sensor, and it was 0.0 Volt. I had misinterpreted the pin-layout, and swapped it 180 degrees. I moved the connetions to the correct end of the socket, and now things work just fine.

-1

Looking at the datasheet for the DS18B20, the input voltage is 3.0 to 5.5. Thinking that perhaps the 3v3 pin wasnt delivering sufficient voltage for whatever reason. Change it to the 5v0 on pin 2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.