0

raspberry pi 3 with raspbian, ssh via macOS

Hi,

I just noticed something awkward. When I tried to login via ssh on my pi, I noticed that I couldn't log in with the password I recently changed with sudo passwd. The password was still the default one. After changing it again, I still wasn't able to log in although no error occurred while changing the password. Then I tried passwd without sudo and it seems to have worked.

But then I noticed that I have 3 pi users??? I have no idea how that happened. I use the pi for running a homebridge server. Thanks! enter image description here

  • 2
    It's not 3 users, it's the same user with 3 terminals open (one of which is graphical desktop) – Dmitry Grigoryev Nov 8 '16 at 11:47
3

When you type sudo passwd you are running the passwd command as the root user, and you are therefore changing the password of the root user, not of the user pi. Only the third time, when you changed the password using just passwd, did you actually change the password of the pi user.

The three users you see are just 3 different login sessions for the same user pi - likely because you didn't completely log out from one or more sessions. I can see a console login and a GUI login in the list.

  • Thanks. Also when I type in users it shows me pi pi pi, is that normal? – Picard Nov 8 '16 at 12:09
  • 1
    Yes, totally normal. users reports a very condensed version of w - just the usernames. Your 3 users are 1) a console login, 2) a GUI login and 3) a remote login (from a machine called "mimis-air"). – Phil B. Nov 8 '16 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.