-1

Just loaded a new image of PIXEL for my Pi 3 . I enabled SSH via raspi-config but was unable to access using SSH (via PuTTY). Tried putting ssh file in /boot/ directory and still didn't work. Any other suggestions on how to access my pi headless?

closed as unclear what you're asking by goobering, Dmitry Grigoryev, Jacobm001, joan, Steve Robillard Feb 15 '17 at 21:18

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Given your description, the answers could even start with: did you connect the power to the Raspberry Pi? You provided zero details. – techraf Jan 29 '17 at 23:30
  • Did you reboot? – Steve Robillard Jan 29 '17 at 23:30
  • Is your pi connected to internet? – ElefantPhace Jan 29 '17 at 23:37
  • Can you check the status of ssh using the command sudo service ssh status. If there are any errors like error: Could not load host key: then clean up the files using the command sudo rm -f /etc/ssh/ssh_host*. Then perform sudo service ssh restart. That should get you going fine. – Varad A G Jan 30 '17 at 4:16
  • go to /etc/ssh/sshd_config and edit mode and put 'PasswordAuthentication yes' – webDev Feb 3 '17 at 22:15
1

Since you provide zero details, let's get started:

Firstly, make sure that the IP on the Pi is correct, if static. If it's dynamic, search for it with an "IP Scanner" until you find a device named like raspberry.

IP Scanner

Once found, try to connect to port 22 (SSH).

Putty Error

If it throws an error, put the card in the PC and be sure that the ssh file is in the main directory of the card, since Windows only shows the boot partition.

Also make sure, that the file is only named ssh - nothing more, nothing less. Under Windows, when you create an "empty" text file, it puts .txt as default file extension and hides it from you, so you wil only see ssh, but actually it is an .txt.

ssh.txt File

To prevent this from happening, search in Windows for "Folder Options" and in the list, disable the tick box named: "Hide file extension on known file types".

Folder Options

After that, go into the directory again and remove the .txt on the end of the file and confirm the warning dialog.

Removing .txt

Confirming warning dialog

-1

Make sure that you have assigned a static ip to your pi. If you are not sure about it then then scan your network using fing(or other relevant apps) on your android phone and get ip address of raspberry pi.

Assign a static ip to your pi from DHCP settings of your router if you haven't done.

If you have enabled SSH before loading new image revisit raspi-config. Make sure you have selected SSH on your putty.Hope it helps!

Not the answer you're looking for? Browse other questions tagged or ask your own question.