I'm relatively new to Raspberry Pi in general, my basic experience is with loading XBMC or Noobs.

I've got a project with work that I'd like to utilize Raspberry Pi as a terminal which only needs a web browser. I've installed Flint OS (other recommendations are welcome). The operating systems seems to be what we need, but our network requires validation of the MAC address.

Is there a way to get this from Flint OS?

I've tried using Ctrl+Alt+F2 as is available in older versions of Chromium OS, but it crashes Flint every time. Also, I am currently connected via WiFi which is the only reason I need the MAC address.

  • Have you tried getting it from your router? – Steve Robillard Feb 22 '17 at 21:41
  • I have not. But I do not have administrative rights, so I'll need to bring it up with the boss. Thanks for the suggestion. – tbm0115 Feb 22 '17 at 21:57
  • I'd maybe be just a little cautious about using a 3 month old OS fork for something at work. Exciting new toys tend to exhibit exciting new behaviours until they get past the teething troubles. Are there specific features that would rule out core chromium (which would let you access the terminal again)? – goobering Feb 23 '17 at 0:26
up vote 0 down vote accepted

Please type ctrl+alt+t from your browser window. This opens the crosh terminal. crosh>

Now, type 'shell' (without the quotes). You will have access to bash and can do whatever you wanted to with the ctlrl+alt+f2.

The system currently freezes with ctrl+alt+f2. Press ctrl+alt+f1 to get back to the GUI.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.