0

I'm having trouble using one of the GPIO pins. When trying to use BCM 12 (PIN 32 in BOARD mode, name: GPIO26) as an output, I get the warning:

RuntimeWarning: This channel is already in use, continuing anyway.

According to gpio readall, this pin is not in use and correctly set to out mode. Disabling the warnings didn't help.

This pin is supposed to be the trigger for an ultrasound sensor. My current system uses four of those, with triggers on other pins, and three of them work perfectly. The one on BCM 12, however, does not seem to switch the trigger on. The sensor works fine on other pins, yet I cannot switch to another pin, since all others are used for something else.

Is it possible that BCM 12 is broken or being used by a service I have inadvertently activated? I have double, triple and quadruple checked that it is not a wiring problem.

I am using Raspbian Stretch (the issue is the same on Jessie) on a Raspberry PI 3 B. All packages are up to date, including the firmware. There are four ultrasound sensors connected, a gyro-sensor, a gps-sensor, six ESCs (including motors), and all work fine with said ultrasound sensor being the only exception. For accessing the pins, I use PIGPIOD and python 3.

Can anyone help? Best regards Reto

  • I think that you are confusing pin names. Take a look here: pinout.xyz and edit your question. – user51705 Aug 22 '17 at 8:46
  • Nope - issuing "gpio readall" provides a list of PINs and their respective names. Thus: BCM 12 = PIN 32 (invoked by setting the mode to BOARD) = GPIO 26. I really mean BCM 12, as is described by the link you provided. – Reto Schölly Aug 23 '17 at 15:20
  • No. The mode "BOARD" is something internal to the Python library you use. BCM 12 is pin 32 and is GPIO 12. GPIO 26 is pin 37. – user51705 Aug 23 '17 at 21:03
0

The pigpio daemon does not issue that warning (warning, not error).

The message is issued by the RPi.GPIO Python module. If I remember correctly RPi.GPIO tells you what do do if you don't want it to print that message. For details on what the message means refer to the RPi.GPIO documentation.

  • The pigpio daemon indeed does not issue that warning. However, I am having trouble both using RPi.GPIO and pigpio. RPi.GPIO just gives me the warning I cited above, but does not explain the problem in greater detail. – Reto Schölly Aug 23 '17 at 15:21
0

Okay, I solved the problem. It was a stupid mistake on my part.

I discovered that the external circuits, which I soldered myself, had one broken soldering joint. I have quite some electronics outside the Raspberry PI, and although my board worked perfectly before installing it, it broke while placing it into the casing. What a shameful mistake!

Sorry to have wasted everyone's time! And thank you for your trying to help me!

Best regards Reto

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.