0
         iPhone (Works)
            |
            v
    Bluetooth Channel (Connected)
            |
            v
       Raspberry PI (Works)
            |               
            v
      Headphone jack (Works)
            |
            v
         Speakers (No Sound)

I’m not getting any sound to play through my set up. I’m using an Aux cable from my Raspberry PI 2 B to my built in stereo system.

I spent most of the night getting my iPhone to connect to my pi via Bluetooth. I have that working. The only thing left to do is figure out why there is no audio coming through. I tested the Aux cable and stereo first by plugging my phone in directly. That works so its not an issue with the Aux cable or the phone or the speakers.

Update

I have Pulse Audio installed and I seem to be having a lot of the same errors most people get... doesn't look like my situation is uncommon. I opened up alsa mixer GUI as my last ditch effort but I didn't find anything useful. I'll check this thread tomorrow to see if there are any suggestions on how to get this issue resolved.

  • Check to see if pulse audio is muted. I had the same problem. pactl set-sink-mute 0 0 might be the command. This is on the basis you are connecting without error in the first place. – tobyd Jan 24 '18 at 9:09
  • 2
    I'd suggest editing the title to be more pertinent to the question. – NomadMaker Jan 24 '18 at 9:42
  • first time posting on any Q A medium please excuse me if my etiquette is not up to spec – user786666 Jan 24 '18 at 16:37
  • Thank you Toby for sticking to the issue and not getting hung up on the subject line... I will definitely try your suggestion and report back as soon as I do. – user786666 Jan 24 '18 at 16:42
  • @tobyd I tried to "un-mute" pulseaudio... I didn't notice any changes. I do however, hear a light fuzzy sound when running pulseaudio --start – user786666 Jan 24 '18 at 17:03
0

Audio over Bluetooth! My setup was a Pi2 running Raspbian stretch with Pixel. My Super-Sweet-Pro-Audio rig was a pair of old desktop stereo speakers via a 3.5mm jack, this looks like it mirrors your setup. I'm using a 2.1 Bluetooth USB adapter but anything should do, the onboard module on the Pi3 should work nicely. I also have docker installed, that's the only other thing I've installed, I doubt it brings anything to this particular party though.

Get the system up-to-date.

sudo apt-get update
sudo apt-get upgrade

Install bluez and the pulse audio module.

sudo apt-get install -y bluez pulseaudio-module-bluetooth
sudo systemctl restart bluetooth

Enable Bluetooth on startup, for some reason this was a bit sketchy on my Pi and after reboots it took a while to bring itself back up (2 minutes being a while). I didn't investigate, there was nothing in the log so maybe its set for a delay. Anyway, make sure its enabled via

sudo systemctl enable bluetooth

Setup Bluetooth and pair your Phone - I'm using a Nexus 5X, I don't know what iOS does.

sudo bluetoothctl

to get into the Bluetooth CLI, then type these commands in (KeyboardOnly is case sensitive!)

agent KeyboardOnly
default-agent
power on
scan on

They set the authentication agent to be the keyboard, powers up the device and starts it scanning for people to talk to - with your phone as discoverable you should see it appear in the console, then connect to it via

connect <mac address> (you can press tab and it should fill it in!)

You'll have to enter the code from your phone into the console, or, ok the dialog (if using the GUI).

You should now be paired - this step is woolly, I don't know how iPhones do things on Bluetooth so you might have to play until its paired. There are other Bluetooth options for pairing but that code one seems fair enough. You can always go back and redo that step with a more fitting implementation later on.

Exit from bluetoothd by typing exit

Next its fighting with pulse audio...Unmute it

pactl set-sink-mute 0 0

then set the volume (0 = 0%, 65536 = 100%)

pactl set-sink-volume 0 32768

I'm setting it for 50%, you should be able to control it via the UI though.

Now you should be able to fire up whatever you want on your phone and it'll play over Bluetooth. I had issues where pulseaudio (via pactl) needed muting and unmuting a few times before it would co-operate.

If you aren't using a desktop (Raspbian Lite / Arch) then you probably won't have PulseAudio running by default and you'll have to do some extra work. I've got this working too but it's a little more involved - I can update this with those steps if that's what you are after.

There are errors in the Bluetooth log sudo journalctl -u bluetooth will probably show them. The Sap one can be made to go away if you really want (you tell bluetoothd to not load that). I've never looked at the RFCOMM voice gateway one....

  • Thanks again @tobyd I'll give this a try and let you know how it goes :D – user786666 Jan 27 '18 at 0:35
  • when I run the command > sudo pacmd, I see this message: No PulseAudio daemon running, or not running as session daemon. – user786666 Jan 27 '18 at 1:22
  • I'm not sure if that is relevant to the issue. Theres still no luck on getting any sound to work. I appreciate your on going support. – user786666 Jan 27 '18 at 1:24
  • I'm wondering if theres another way to approach this without pulseaudio or if I should keep cracking away at this – user786666 Jan 27 '18 at 1:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.