3

I want to install the Raspberry Pi 3 device program. But I have such a problem. I searched on the internet, but the suggested solutions did not work. I am using the latest update of Visual Studio. I have experienced this problem before, but then it has recovered to itself. Now it has appeared again. How do I solve this problem? The problem is as follows:

enter image description here

enter image description here

enter image description here

The output is: "DEP6957: Failed to connect to device '169.254.5.171' using Universal Authentication. Please verify the correct remote authentication mode is specified in the project debug settings. MissingMethodException - Metod not found: 'Void Microsoft.Tools.Connectivity.RemoteDevice.set_Protocol(TransportProtocol)'. [0x80131513]" The problem is that despite my connection failure, my ip address is correct. Because I can access the Device Portal with this IP from the IoT Dashboard program. Note: I'm not connected to the device by wifi. I'm connected with Ethernet.

  • I think the best solution is to not corrupt a nice little embedded machine with Windows ;-) – Chad G Apr 17 '18 at 16:34
  • 1
    @ChadG Did I just hear the echo of yesteryear? DotNetCore is already making a massive dent on cross platform.. NATIVE app deployments. Anyway.. I understand that electrical engineers live and breathe C/C++ but your comment.. may have still been funny 3 years ago.. but today its just ignorant and nonconstructive to be honest. – Piotr Kula Apr 18 '18 at 8:23
  • @akin The dialog says There were deployment errors - You need to open the Output console and look at the error. Maybe its a build failure, a communication issue or something. There will be a useful message somewhere in the output windows. You may need to change between, Debug, Deploy, Console, etc etc. Please check and update your question – Piotr Kula Apr 18 '18 at 8:25
  • @ppumkin The output is: "DEP6957: Failed to connect to device '169.254.5.171' using Universal Authentication. Please verify the correct remote authentication mode is specified in the project debug settings. MissingMethodException - Metot bulunamadı: 'Void Microsoft.Tools.Connectivity.RemoteDevice.set_Protocol(TransportProtocol)'. [0x80131513]" The problem is that despite my connection failure, my ip address is correct. Because I can access the Device Portal with this IP from the IoT Dashboard program. Note: I'm not connected to the device by wifi. I'm connected with Ethernet. – Akın Şibay Apr 18 '18 at 10:18
  • 2
    @ppumkin I started Visual Studio as an administrator and successfully deployed it! Thank you so much for your reply, I've been dealing with it for days :) – Akın Şibay Apr 18 '18 at 13:06
1

If it was working BEFORE and suddenly stopped make sure that your development machine has an up to date SDK. Windows IoT has automatically updated enabled by default now so make sure all your updates are installed especially the SDK and VS

Otherwise - In Visual studio the first things you can try are

  • Clean the solution
    • Then actually go into the bin folders and make sure they are all empty
  • On the solution Properties => Debug : Check the "Uninstall and then reinstall package "
  • Try and deploy again as you would normally

If that has not fixed the issue then this simple yet highly effective step fixes the problem most of the time.

  • Shut down all instances of visual studio
  • Run a new one in Administrator mode and try to deploy/debug again

There is some kind of caching issue within Visual Studio (even though you put in IP)

  • Restart your machine and the Rasbperry Pi

More steps to try if after restart still having issues. Close all visual studio and shut down Raspberry Pi - Open command line in Admin mode

  • ipconfig /release (releases DHCP on all interfaces)
  • ipconfig /renew (asks for new DHCP on all interfaces)
  • ipconfig /flushdns (flushes the ARP cache)
  • boot up Raspberry Pi and access via browser IP or DNS

If that still has not resolved the issue you can try some more, rarely needed commands in the event of a royal stuff up

  • netsh int ip reset c:\tcp.txt
  • netsh winsock reset
0

I had the same issue on a 2 projects and eventually figured out that the Target Version (VS Project--> Properties --> Application -->Targeting -->Target Version:) was set to a lower version than what I was running on my Raspberry Pi (visible on Pi IOT landing page).

After updating the Target Version for the project in VS to match the version I installed on the Pi I could successfully deploy again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.