1

I'm running arch linux (aarch64 kernel 4.16.9) on a Raspberry 3b, and using the text mode console on a monitor attached to the HDMI port. Everything basically works on the device, except for one problem: periodically, the console switches from whatever I'm working on to a boot screen containing boot messages, whose last line is fb: switching to vc4drmfb from simple. At that point I can't type anything. To switch back to my work, I need to switch to a different VT (ctrl-alt-f2) and then switch back (ctrl-alt-f1). If more than one VT is in use (e.g., both tty1 and tty2), then I need to switch to an unused one (ctrl-alt-f3) before switching back.

My question is how to stop this annoying switching behavior. Could it be tied to some sort of screen saver misconfiguration (certainly no screen saver ever kicks in)?

For what it's worth, this happened when my kernel command line from boot.txt was the default:

console=ttyS1,115200 console=tty0 root=PARTUUID=${uuid} rw rootwait smsc95xx.macaddr="${usbethaddr}"

I tried removing the first console argument (console=ttyS1,115200) and rebooting, but I get the same problem.

  • Does it really switch or is it just that kernel messages appear on your console? – Gerard H. Pille May 24 '18 at 6:44
  • @GerardH.Pille Yes, it really switches (only the boot messages, not what I have been doing on the console), and when I switch back by cycling VTs, I get the old screen contents back. So this is definitely some kind of console mode switch akin to an involuntary VT switch. – user3188445 May 24 '18 at 7:45
  • Does it switch only when you are working on it or does is switch when left alone too? What are you doing when it switches? – Craig May 24 '18 at 15:40
  • @Craig It usually seems to switch when left alone for a few minutes, but I don't know if this is 100% the case. I think I've seen it happen in only a minute or so, so much faster than the screen saver should kick in. – user3188445 May 25 '18 at 1:01
  • @Craig actually, it seems to happen even while I'm working, so doesn't only happen while the computer is idle. – user3188445 May 26 '18 at 23:33
3

In thanks to Gerard's answer I was able to find a comment in that bug chain with a successful workaround to this problem, it took me some time to find so I will provide it here for anyone else searching:

echo blacklist vc4 > /etc/modprobe.d/blacklist-vc4.conf

To explain, Sylvain Pasche avoids this hangup by blacklisting the vc4 driver. Ryniker notes this will disable graphical acceleration but does allow you to avoid the issue that freezes your screen.

| improve this answer | |
1

According to this bug (https://bugzilla.redhat.com/show_bug.cgi?id=1387733) it could depend on your monitor and the resolution used. Try another monitor or a lower resolution.

| improve this answer | |
  • Thanks for the suggestion, but this is not that bug, as the console still works, it just involuntarily switches me to that boot screen with the initial boot messages, forcing me to switch back. That bug was about a blank console that was unrecoverable. – user3188445 May 24 '18 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.