1

I am using Raspberry pi 2 with kernel version 3.18.11-v7+ and HDMI to VGA converter to connect to Monitor.

Every time I disconnect the power supply and boot, blank screen appears. When I reboot, screen appears.

Steps tried so far:

  1. Enabled boot to desktop in sudo raspi-config. After setting boot to desktop, raspberry pi auto reboots and screen appears. But when ever I shutdown and boot again, no screen on display.
  2. Edited /boot/config.txt file:
    • uncommented hdmi_safe=1 and disable_overscan=1. Screen appears after every shutdown but with very low resolution.
    • commented hdmi_safe=1 and uncommented hdmi_group=2 and hdmi_mode=86 to force into hdmi mode. The resolution got corrected after reboot but after shutdown boot, no screen appears.
    • uncommented hdmi_safe=1 and uncommented hdmi_group=2 and hdmi_mode=86 to force into hdmi mode. Screen appears after every shutdown but with very low resolution.

Any workaround to solve this issue?

0

According to the documentation, setting hdmi_safe=1 is the equivalent of setting a bunch of things including a low resolution hdmi_mode. You might try re-ordering the lines to see if you can override that with a mode set before or after (I think usually lines later in config.txt take precedence, but I have not experimented extensively with that).

Anyway, looking at the list of things invoked by hdmi_safe=1, you could instead try:

hdmi_force_hotplug=1
hdmi_ignore_edid=0xa5000080
config_hdmi_boost=4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.