1

I'm trying to connect form my laptop to my pi with ssh but i get Permission denied, when insert the password. I do: ssh pigio@192.168.178.79

  • I'm sure the ip address is correct because i can PING and get response.
  • I'm quite sure the password i'm typing is the same (keyboard layout) because i type on note pad on both machine so i can see it and look the same.
  • i can connect with ssh from my pi to the pi with ssh localhost, inserting the password that i note down.
  • i edit my network from /etc/wpa_supplicant/wpa_supplicant.conf but it didn't connect, so i then connect with wifi OS settings. The configuration on the wpa_supplicant.conf file is still there, tho.

I'm in wlan (yes, same network), raspberry pi 3, mac last OS.

Is there anything else i can try to debug or see why it wouldn't work?

UPDATE: Look like RSP has issue to naturally connect to 5Ghz network. Or maybe just with dual band network. Could someone confirm this? There is any relativly simple solutions for Mac?

UPDATE 2 Ping result:

PING 192.168.178.79 (192.168.178.79): 56 data bytes
64 bytes from 192.168.178.79: icmp_seq=0 ttl=64 time=18.553 ms
64 bytes from 192.168.178.79: icmp_seq=1 ttl=64 time=33.489 ms

ssh -vvv pigio@192.168.178.79 -p 22

OpenSSH_7.6p1, LibreSSL 2.6.2
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 48: Applying options for *
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 192.168.178.79 port 22.
debug1: Connection established.
debug1: identity file /Users/anaketa/.ssh/id_rsa type 0
debug1: key_load_public: No such file or directory
debug1: identity file /Users/anaketa/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /Users/anaketa/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /Users/anaketa/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /Users/anaketa/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /Users/anaketa/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /Users/anaketa/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /Users/anaketa/.ssh/id_ed25519-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4p1 Raspbian-10+deb9u3
debug1: match: OpenSSH_7.4p1 Raspbian-10+deb9u3 pat OpenSSH* compat 0x04000000
debug3: fd 5 is O_NONBLOCK
debug1: Authenticating to 192.168.178.79:22 as 'pigio'
debug3: hostkeys_foreach: reading file "/Users/anaketa/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /Users/anaketa/.ssh/known_hosts:32
debug3: load_hostkeys: loaded 1 keys from 192.168.178.79
debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-ed25519,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos: 
debug2: languages stoc: 
debug2: first_kex_follows 0 
debug2: reserved 0 
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1
debug2: host key algorithms: ssh-rsa,rsa-sha2-512,rsa-sha2-256,ecdsa-sha2-nistp256,ssh-ed25519
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com
debug2: compression stoc: none,zlib@openssh.com
debug2: languages ctos: 
debug2: languages stoc: 
debug2: first_kex_follows 0 
debug2: reserved 0 
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:tO/pT+gnUbIvtAaoh7xaxp6jrQlz1X6hS4PMw6ZEFRQ
debug3: hostkeys_foreach: reading file "/Users/anaketa/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /Users/anaketa/.ssh/known_hosts:32
debug3: load_hostkeys: loaded 1 keys from 192.168.178.79
debug1: Host '192.168.178.79' is known and matches the ECDSA host key.
debug1: Found key in /Users/anaketa/.ssh/known_hosts:32
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey after 134217728 blocks
debug2: key: /Users/anaketa/.ssh/id_rsa (0x7fbac6d0a3d0)
debug2: key: /Users/anaketa/.ssh/id_dsa (0x0)
debug2: key: /Users/anaketa/.ssh/id_ecdsa (0x0)
debug2: key: /Users/anaketa/.ssh/id_ed25519 (0x0)
debug3: send packet: type 5
debug3: receive packet: type 7
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: RSA SHA256:wAWUzMySNDUJjmwLlmPkkRvfwzyTF+LMGQTKtWtQaP4 /Users/anaketa/.ssh/id_rsa
debug3: send_pubkey_test
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /Users/anaketa/.ssh/id_dsa
debug3: no such identity: /Users/anaketa/.ssh/id_dsa: No such file or directory
debug1: Trying private key: /Users/anaketa/.ssh/id_ecdsa
debug3: no such identity: /Users/anaketa/.ssh/id_ecdsa: No such file or directory
debug1: Trying private key: /Users/anaketa/.ssh/id_ed25519
debug3: no such identity: /Users/anaketa/.ssh/id_ed25519: No such file or directory
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
pigio@192.168.178.79's password: 
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
pigio@192.168.178.79's password: 
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
pigio@192.168.178.79's password: 
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
pigio@192.168.178.79: Permission denied (publickey,password).

@Fabian I post the log as new answer because is too long and it doesnt allow me to post it:

Log of pigio, logged in as pi:

Jun 10 21:34:13 pigio sshd[1086]: Invalid user pigio from 
192.168.178.70 port 56997
Jun 10 21:34:13 pigio sshd[1086]: input_userauth_request: invalid user pigio [preauth]
Jun 10 21:34:16 pigio sshd[1086]: pam_unix(sshd:auth): check pass; user unknown
Jun 10 21:34:16 pigio sshd[1086]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.178.70
Jun 10 21:34:18 pigio sshd[1086]: Failed password for invalid user pigio from 192.168.178.70 port 56997 ssh2
Jun 10 21:34:21 pigio sshd[1086]: pam_unix(sshd:auth): check pass; user unknown
Jun 10 21:34:23 pigio sshd[1086]: Failed password for invalid user pigio from 192.168.178.70 port 56997 ssh2
Jun 10 21:34:25 pigio sshd[1086]: pam_unix(sshd:auth): check pass; user unknown
Jun 10 21:34:27 pigio sshd[1086]: Failed password for invalid user pigio from 192.168.178.70 port 56997 ssh2
Jun 10 21:34:28 pigio sshd[1086]: Connection closed by 192.168.178.70 port 56997 [preauth]
Jun 10 21:34:28 pigio sshd[1086]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.178.70
Jun 10 21:34:47 pigio sshd[1109]: Invalid user pigio from 192.168.178.70 port 57000
Jun 10 21:34:47 pigio sshd[1109]: input_userauth_request: invalid user pigio [preauth]
Jun 10 21:34:50 pigio sshd[1109]: pam_unix(sshd:auth): check pass; user unknown
Jun 10 21:34:50 pigio sshd[1109]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.178.70
Jun 10 21:34:53 pigio sshd[1109]: Failed password for invalid user pigio from 192.168.178.70 port 57000 ssh2
Jun 10 21:34:55 pigio sshd[1109]: pam_unix(sshd:auth): check pass; user unknown
Jun 10 21:34:57 pigio sshd[1109]: Failed password for invalid user pigio from 192.168.178.70 port 57000 ssh2
Jun 10 21:34:59 pigio sshd[1109]: pam_unix(sshd:auth): check pass; user unknown
Jun 10 21:35:01 pigio sshd[1109]: Failed password for invalid user pigio from 192.168.178.70 port 57000 ssh2
Jun 10 21:35:02 pigio sshd[1109]: Connection closed by 192.168.178.70 port 57000 [preauth]
Jun 10 21:35:02 pigio sshd[1109]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.178.70
Jun 10 21:35:35 pigio systemd-logind[343]: New seat seat0.
Jun 10 21:35:36 pigio sshd[450]: Server listening on 0.0.0.0 port 22.
Jun 10 21:35:36 pigio sshd[450]: Server listening on :: port 22.
Jun 10 21:35:39 pigio lightdm: pam_unix(lightdm-autologin:session): session opened for user pi by (uid=0)
Jun 10 21:35:39 pigio systemd-logind[343]: New session c1 of user pi.
Jun 10 21:35:39 pigio systemd: pam_unix(systemd-user:session): session opened for user pi by (uid=0)
Jun 10 21:35:41 pigio login[442]: pam_unix(login:session): session opened for user pi by LOGIN(uid=0)
Jun 10 21:35:41 pigio systemd-logind[343]: New session c2 of user pi.
Jun 10 21:35:42 pigio polkitd(authority=local): Registered Authentication Agent for unix-session:c1 (system bus name :1.14 [lxpolkit], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Jun 13 19:43:51 pigio sshd[1019]: Accepted password for pi from 192.168.178.70 port 49273 ssh2
Jun 13 19:43:51 pigio sshd[1019]: pam_unix(sshd:session): session opened for user pi by (uid=0)
Jun 13 19:43:51 pigio systemd-logind[343]: New session c3 of user pi.
  • 1
    check /var/log/auth.log | connect using ssh -vvv and set the destination port: ssh -vvv pigio@192.168.1xx.xx -p 22 – Fabian Jun 2 '18 at 20:08
  • 1
    Is pigio a new user created by you ? Default user is pi , usually . So would be ssh pi@192.168.1xx.xx the right thing. – E_Angel Jun 2 '18 at 21:09
  • @E_Angel - if there was a problem with user pigio, then OP couldn't ssh from my pi to the pi with ssh localhost – Jaromanda X Jun 2 '18 at 23:42
  • note: no need to obfuscate local private IP address like any 192.168.x.x IP ... my pi is 192.168.1.19 - but that doesn't make it accessible to you :p – Jaromanda X Jun 2 '18 at 23:43
  • @JaromandaX so you did create a new user ?? – E_Angel Jun 3 '18 at 1:11
0

As it turned out you are facing two issues:

1) Connectivity

Your wifi uses the 5 GHz band but your Raspberry Pi 3 Model B can only connect to 2.4 GHz band wireless LAN (to be exact: "802.11n Wireless LAN", see Hardware Guide). As a result of the missing connectivity your RPi is not accessible from your Mac using SSH.

Suggested solution: connect your RPi using 2.4 GHz or use a Raspberry Pi 3 Model B+ (which supports dual-band wireless LAN) and connect it to 5 GHz.

2) User

Side note #1: "pigio" is (or: should be) the name of a user on this RPi and the hostname of this RPi.
Side note #2: /var/log/auth.log is located on the RPi.

You've successfull established a SSH connection from your laptop to your RPi by using the default user "pi", seeable in /var/log/auth.log:

Jun 13 19:43:51 pigio sshd[1019]: Accepted password for pi from 192.168.178.70 port 49273 ssh2
Jun 13 19:43:51 pigio sshd[1019]: pam_unix(sshd:session): session opened for user pi by (uid=0)

Conclusion: SSH is working (you've assumed it and now it's verified).

The SSH connection fails with the user "pigio" like documented in /var/log/auth.log:

Jun 10 21:34:13 pigio sshd[1086]: Invalid user pigio from 192.168.178.70 port 56997
Jun 10 21:34:13 pigio sshd[1086]: input_userauth_request: invalid user pigio [preauth]

Most probably the user "pigio" doesn't exist. To verify: please connect again to your RPi as the user "pi", run sudo grep -i pigio /etc/passwd. (Background information: This command will search case-insensitive for the username "pigio" in the user account information file of Raspbian and therefor it needs sudo power.)
If the result is empty (you see the cursor in a new blank line waiting for your next input) then the user does not exist (please see below for how to create a user).
If the result is something like pigio:x:1001:1001:,,,:/home/pigio:/bin/false then indeed the user does exist.

As it turned out the user "pigio" is nonexistent.

Suggested solution: create the user "pigio" and assign a password by:

sudo useradd --create-home --shell /bin/bash pigio
sudo passwd pigio

Another way to create a new user is adduser. For the differences please read the manpages: man useradd respective man adduser.

If you want to add the new user to sudoers and grant passwordless sudo access, then please read the official Raspberry Pi Documentation - User management in Raspbian.


To answer your comment "I will not have more then one user anyway": you can use the default user "pi" but it is not recommend for security reasons. I recommend to

But this is getting to be off-topic, so I'd suggest for details you please read Securing your Raspberry Pi - Raspberry Pi Documentation.

  • 1
    Hey @Fabian thank you again for your answer! I finally manage to set up my connection also to a 2.4 GHz and yes is a 802.11n LAN. Now when i ssh from my laptop, i get asked 3 times for a password and then for the pi's password. But again, access is denied :( I check in /var/log/auth.log and i don't see any log from when i connect with my laptop – Giorgia Sambrotta Jun 7 '18 at 22:00
  • I also try: ssh 192.168.xxx.xx -l pigio and got asked for pigio's password three times directly. and got Permission denied (publickey,password) – Giorgia Sambrotta Jun 7 '18 at 22:08
  • 1
    Ah! but i can log in with default user! But then, why cant i use that one? I will not have more then one user anyway... Anyway i update the question with the log, hopefully make more sense for you – Giorgia Sambrotta Jun 13 '18 at 19:55
  • Look like the user pigio doesn't exist... did i maybe just change the visual name and not really the user name? I didn't see any other place in the config screen where to change the user name. Also, i follow a tutorial :/ – Giorgia Sambrotta Jun 13 '18 at 19:57
  • 1
    THANK YOU!!!! The user indeed didn't exist! I create a new one and now i can easily access it! Not sure why it didn't exist tho, since i can see the name on my RPI.. But i create the user with the config screen in the pi, not from the terminal! I'm so happy i can go on with my project, really really thank you for your time and dedication, i'm glad there are people like you in our community! :) – Giorgia Sambrotta Jun 15 '18 at 8:36
1

Make sure you activated ssh in the raspi-config!
-> sudo raspi-config -> Interfacing Options -> ssh -> enable

  • 1
    yes, it is! I can also ssh localhost and insert my password correctly (i get error if i put the wrong password) – Giorgia Sambrotta Jun 3 '18 at 10:49
  • Have you tried usermod -U <user>? – itzFlubby Jun 3 '18 at 11:51
  • Also, in /etc/ssh/sshd_config you should uncomment #PasswordAuthentication yes – itzFlubby Jun 3 '18 at 11:54
  • nope, what is/how to use usermod -U <user>? And i try to find the sshd_config file but i have none (on the pi) – Giorgia Sambrotta Jun 3 '18 at 12:24
  • The config file should be there. Please check again and make a complete search on your system if the file exists. The usermod -U <user> command unlocks the user, if it is locked in any way. – itzFlubby Jun 3 '18 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.