0

I have a problem with mouse and keyboard on my raspberry pi. When I connect two usb device they don't work and if I go in /var/log/syslog I found this error:

mtp-probe: bus: 1, device: 6 was not an MTP device

If I make lsusb I see both the devices as recognized

Kernel 4.14.44-v7+

And I tried, at the starting before the boot, to press on my keyboard shift for start recovery, and in this moment mouse and keyboard works, so I exclude a USB hardware error

How can I resolve this problem?

  • what is the output of lsusb when both devices are connected? Add it as additional information to the question, please. – eftshift0 Jun 6 '18 at 4:44
  • Thank you If I make lsusb I see both the devices as recognized. I added this detail in my question – LorenzoBerti Jun 6 '18 at 4:46
  • Assuming that both devices are recognized and the drivers are loaded accordingly, my question would be: Do you have enough power for it? What model of pi are you using and many volts/amperes does the power source provide? – eftshift0 Jun 6 '18 at 5:00
  • Thank you, I have the original power source and furthermore, at the start, I can press shift for start the recovery, and in the recovery system the mouse and keyboard works, I suppose that was the power, Mouse and keyboard shouldn't work never. – LorenzoBerti Jun 6 '18 at 5:15
  • When do they stop working? Later after the boot process is done and the desktop environment starts? – eftshift0 Jun 6 '18 at 5:21
1

This is not an answer to the question you asked, but I note you are using Kernel 4.14.44-v7+

This is probably because you have run rpi-update, and may have nothing to do with your problem, but there is no reason to run unsupported testing software. It is difficult for those running the current OS to know.

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware." sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

  • hello thankyou, so if I execute apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel I will return at the latest stable version? this evening I will try, than you for this advise! – LorenzoBerti Jun 6 '18 at 8:16
  • I tried to reinstall and now I have 4.9.35-v7+ but he problem persist :( – LorenzoBerti Jun 6 '18 at 21:55
  • @LorenzoBerti From your comment it seems you are using (soon to be unsupported) Jessie, presumably installed by an old version of NOOBS. This is information which should be included in your question (preferably in tags). Rather than running questionable updates, you would have been better installing Stretch – Milliways Jun 6 '18 at 23:56
  • Hello, I have raspberry from 2016 so I have jessie, yes, this evening I will try to recovery all and upgrade to Scretch. – LorenzoBerti Jun 7 '18 at 10:35
  • @Millways - how am I to run all those commands in those solutions if my keyboard and mouse doesn't work? StackOverflow doesn't allow me to ask the question as a comment to the last answer (I am new here). I'm sorry for posting this as an answer. – Nikhil Bhirud Apr 1 at 4:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.