3

I have a Pi version A (256MB), running RaspBMC (I guess the latest version as I only created the SD a month or so ago).

When I try to play some AVI files I have no problems adn everything works fine. When I try to play others I can hear the sound but the image stays on the navigation screen, without freezing so I can still scroll around and access sub-menus. Any idea what may be causing this behaviour?

Thanks

  • Will these same files play okay on a Windows, (or other 'package system') without issue? You may want to try one of the many video repair systems out there, and also verify that you have the correct codecs installed. – Butters Aug 15 '13 at 15:09
  • I can play the files fine in VLC on Ubuntu 12, which I have running on my laptop. How can I check that I have the correct codecs installed? (my mouse does not seem to want to work when I connect it to the Pi I am just using a remote control). – Chris Aug 15 '13 at 15:27
  • Sounds like it is not a file issue then... That is a good question... One that I don't have the answer to... – Butters Aug 15 '13 at 16:18
  • If in VLC you go to Tools > Codec Information it should tell you what CODECs are being used for the file, it does sound like the AVI in question uses a video CODEC RaspBMC does not have installed – PiBorg Aug 15 '13 at 17:11
6

This sounds very much like some of your AVI files have video encoded with MPEG-2 or VC1 (or possibly some other unsupported codec) and you don't have the MPEG-2 or VC1 codec installed (only h.264/MPEG-4 content can be played by default). I had exactly the same issue when I first installed RaspBMC and tried to play DVD content (it plays like an audio file, in the background, as you describe). The RaspBMC FAQ says:

Q: Can Raspbmc play back MPEG2 or VC1?

A: Yes! Raspbmc offers hardware decoding of these codecs, provided the codec pack has been purchased from the Raspberry Pi foundation website here

You can find out the particular codec you need by opening the "Media Information" window in VLC then clicking the "Codec Details" tab (the screenshot below was taken on a Mac, but I imagine the Linux version will be similar). The video stream is usually Stream 0. If its MPEG-2 or VC1 then you should be able to purchase a codec and play it just fine.

enter image description here

Note that (at time of writing) the Raspberry Pi does not support playback of files encoded with the DIVX3 codec, which appear in VLC as type "MPEG-4 Video v3 (DIV3)". This Raspberry Pi forum topic has a reply from dom (near the bottom) which confirms this:

That is not MPEG 4 compliant and not supported. DIVX3 is actually a codec reverse engineered from an old Microsoft codec, than was a non-standard variant of MPEG 4. The hardware codec can't support it.

In order to get around this, you should be able to re-encode the file to one of the supported formats. The answer to this question includes a script that claims to convert from DIVX3 to H.264 (which then should be playable on the Pi without purchasing a codec). It looks like it uses avconv to do the legwork. I've not tried it, so use at your own risk.

The How-To Geek article How to Add MPEG-2 and VC-1 Video Codec Support to Your Raspberry Pi contains an excellent tutorial on what to do from here, but in a nutshell, once you've purchased the relevant codec, the license file will get emailed to you. You can then install the codec by following the instructions in the How-To Geek article above or How Do I Add Codecs? section of the RaspBMC/FAQ.

  • I have checked it VLC and it appears to be using MPEG-4 – Chris Aug 16 '13 at 8:42
  • Stream 0: Type: Video Codec: MS MPEG-4 Video v3 (DIV3) Resolution: 512x384 Frame rate: 23.976000 Decoded format: Planar 4:4:0 YUV Stream 1 Type: Audio Codec: AS2 Audio (aka AC3) (a52) Channels: Dolby Sample rate: 48000 Hz Bitrate: 192 kb/s – Chris Aug 16 '13 at 8:52
  • Unfortunately, according to this post it seems you have a DIVX3 file and this format isn't playable on the Pi. Looks like you might have to re-encode it instead. – binarybob Aug 16 '13 at 9:43
  • Just to add to my comment above, this Raspberry Pi forum post from dom (near the bottom) confirms it: "That is not MPEG 4 compliant and not supported. DIVX3 is actually a codec reverse engineered from an old Microsoft codec, than was a non-standard variant of MPEG 4. The hardware codec can't support it." – binarybob Aug 16 '13 at 9:56
  • 1
    Then you should mark that answer should as correct – Tevo D Aug 20 '13 at 19:22
1

I've used Any Video Converter, it's a Windows programs that gives many options when converting. http://www.any-video-converter.com/products/for_video_free/

1

Use ffmpeg on your desktop to re encode the files in question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.