0

Going through this thread:

proxy ARP WiFi bridge Raspberry

Ingo´s solution is working fine for me but I´m looking for an extra... With this WiFi bridge I want to use an add USB-Ethernet adapter (with fixed IP address). Both bridge and adapter work separately, but if I plug the cable in the new adapter, I lose internet connection in my bridge. The strange thing is that I´m able to go until the router, but I can not go outside. And as I told before without any cable plugged in everything is working well.

Does anyone know how to avoid this problem?

  • I fixed some grammar, please double check that the question is still what you intended to ask. – Dmitry Grigoryev Jan 14 at 12:01
  • I will have a look at it. It takes a little bit of time. – Ingo Jan 14 at 23:56
  • I have just setup a proxy arp router as described behind the link you have given in your question and then plugged in an additional USB-Ethernet adapter as you described. I have no problems even with a plugged in ethernet cable. The additional interface eth1 is just down and doesn't matter and proxy arp is working. What have I to do to get the error? How do you set the static ip address? What have you done different from my setup? – Ingo Jan 15 at 12:20
0

I cannot give some advices to the specific problem asked in the question because I don't get further information from the comments. Maybe the wired connection with an additional USB-ethernet dongle is also connected to the same internet router than the wifi interface and there is a routing problem. But I will show how to use an additional wired connection to a different subnet.

First setup proxy arp as described at Workaround for a wifi bridge on a Raspberry Pi with proxy arp and make sure it's working. That's the same setup used in the question. Then just plug in the USB-ethernet dongle with an ethernet cable to the subnet. With this setup you have to ensure that the new subnet is another one than the wifi has. For example if wlan0 has got an ip address 192.168.50.182/24 by DHCP then eth1 could be set to 192.168.10.60/24. Configure eth1 with this file:

rpi ~$ sudo -Es
rpi ~# cat > /etc/systemd/networki/04-eth1.network <<EOF
[Match]
Name=eth1
[Network]
Address=192.168.10.60/24
EOF

Then restart the network with the new setting:

rpi ~# systemctl daemon-reload
rpi ~# systemctl restart systemd-networkd.service
rpi ~# exit
rpi ~$

Now you can use interface eth0 as faked "bridge" to the wifi subnet 192.168.50.0/24 and you can use interface eth1 to connect the RasPi as normal client to subnet 192.168.10.0/24.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.