2

I want to try out XFCE4 on the raspberry pi. This is mainly because of two reasons:

► I just like XFCE
► I want a bit more flexibility when it comes to GUI scaling - I have a 240x320 LCD and need to scale the GUI to suit, and Pixel (LXDE I understand) doesn't seem to have an option to do that (any help on that would be nice too).

What I have done:

Installed XFCE sudo apt-get install xfce4 x-window-system

Started it with startxfce4

The problem:

The screen goes blank for a second when I try to startxfce4, and then it exits with xinit: unable to connect to X server: Connection refused.

The full log file can be found here.

Thanks in advance.

2

Xorg often needs root permissions to run properly, so it can be problematic to start it as a non-root user from the console. If you want to run it manually without sudo, you should install xserver-xorg-legacy package containing a wrapper which will get root permissions for you via suid bit.

Alternatively, set up XFCE as your default desktop environment (the way LXDE was configured), then you will not need to start it manually.

  • Yes, running it as root worked! I should have thought of that.... – Jachdich Feb 8 at 14:42
  • 1
    @Jachdich Note that running Xorg as root without the wrapper has other annoying consequences, such as root-owned config files in your home folder and some programs intentionally refusing to work when they detect you're running them as root. – Dmitry Grigoryev Feb 8 at 14:47
  • OK, I'll look into setting up that wrapper then. – Jachdich Feb 8 at 14:47
  • 1
    I installed the wrapper, everything works great! – Jachdich Feb 8 at 15:09
  • To avoid running Xorg as root you can specify the tty you are logged into by running startx -- vt# where # is the number of the tty you are logged into. – IronPig Feb 8 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.