1

I've got a very simple setup on my Raspberry pi 2. It's a clean install of the latest version of Raspbian (via NOOBS) with Redshift and QuickSynergy installed. Almost any time I open a web browser, whether it's Midori, Epiphany, or Chromium, the screen fills with one single color (usually gray, though sometimes others - I got a pale red once) and the system is unresponsive. I've tried leaving it for over an hour and nothing seems to fix it. Once or twice instead of filling with a color the monitor has simply disconnected.

I've tried formatting my SD and reinstalling the OS several times now. I'd describe more about my setup but honestly this even happened once right after I'd finished a fresh install of the OS. The RPi has a Trendnet wifi dongle that's worked fine for years until this cropped up about a month ago. Any ideas?

EDIT: Odd thing: I tried Firefox ESR and it seemed to not have the issue (though it ran quite slowly). But after about a week of use, it did the same thing once when I started it. This doesn't appear to be a consistent behavior and I'm having a tough time reproducing it, but it seems to happen more often if I load the Any.do web app (http://web.any.do), especially if it's one of two (or more) tabs.

1

Have you checked your system resources before starting the browser, and while it's starting up? I don't know anything about Redshift and QuickSynergy, but RPi does have limited resources, so worth verifying that you're not out of memory:

1) What happens if neither Redshift nor QuickSynergy are running when you start a browser?

2) If 1) works, start the other 2 apps and run 'top'. Note the CPU and memory values at the top of the screen. If you can't run 'top', use 'vmstat'

  • 1) Since it happened once before I'd even installed either, I don't think they're directly causing the issue (though I could see what you mean about their use of resources not helping). 2)top runs fine - I tried running it on there and Web Content appears to be the command that taking up the most system resources by a long shot. Which makes sense, given the behavior. I didn't realize that would be a separate process from the browser in Linux. Synergy takes maybe 2% of CPU and I don't even see Redshift on the list. – perplexedpi Mar 11 at 14:10
1

I've faced a very similar issue i.e. Chrome or other software in general lags. If this answer doesn't help you, it might help others. I'd leave it here.

Follow the steps below, they have helped me, they might help you.

1 - Change the SD card. I'd prefer Sandisk 3.0.

2 - sudo purge unnecessary programs/software.

3 - systemd-analyze blame => Type the command, check the result, remove unnecessary stuff.

  • Lag doesn't bother me so much, I'm mostly using this as a terminal that I can switch between two tabs every once in a while. It's the crashing that's the problem. Since this is almost entirely a clean install of Raspbian, I don't have a lot to remove. I don't know Linux well enough to start removing built-in OS packages and services. – perplexedpi Mar 11 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.