1

I recently was attempting to connect to my RPi via SSH & Remote Desktop. After several failed attempts from accessing it from windows, I attempted to access it from my Android phone on the same network and everything works fine (SSH, RDP & my webserver on Apache2)

Symptoms: Putty(Windows) Error: - Network error: Permission denied

TightVNC Viewer: - An attempt was made to access a socket in a way forbidden by its access permissions.

Apache2 Webserver - Website loads on Android phone, not on windows

Some things I looked into: -Auth log does not show attempts when connecting with windows - I tried assigning a static IP address (as another thread had suggested) - Disabled Firewall/Defender - Flashed SD and reinstalled (Raspbian GNU/Linux 10 (buster) via NOOBS) - Changed settings in Raspi-config - Verified Pi is on the same network as the desktop via ifconfig - Connected the Pi via ethernet & wifi (Primarily WIFI)

I spent several hours looking this up, and the only possible solution I've found involved a virtual box with Windows XP to connect. I am mostly new to Linux and the RPi platform so any ideas in why I can connect from my android and not my desktop would be appreciated.

Thanks!

Note: NordVPN was running in the background and ended up being the root cause of the connection failures. Thank you all for the feedback!

  • Seems not to be a problem with Raspberry Pi. You should ask on a MS Windows forum. Or you can boot with a Linux live CD (Debian, Ubuntu or any other) and test the connection. – Ingo Nov 5 at 12:00
1

Thank you for taking the time to reply. I wanted to connect through SSH, VNC and FTP, no communications were getting through on any platform I tried. I searched a little bit longer online before stumbling on a Reddit post that did the trick. I use Nord VPN on occasion apparently when the application itself isn't running, this setting affects the services I was trying to use. I am relatively new to RPi so I wasn't sure what I might have missed, you were correct it was an issue with Windows, not Pi.

Reddit:

Ejh0007 1 point 9 months ago So I figured it out. For anyone who comes across this in the future with the same issue. I have NordVPN installed and use it regularly, there is a feature called "Invisibility on LAN". This was blocking local traffic (I couldn't get to my router config page using the web browser.). It seems that even when you're not connected to the VPN and the VPN application is closed it (even if you sign out and then close it) will still block this traffic. I hope this can help someone who encounters the same issue!

  • Using Nord VPN is an important fact causing the error. You should add it to your question so people who look at it, better understand the issue at a first glance. – Ingo Nov 6 at 11:36
  • It was a rather well-hidden issue, the application was not open during the trials the settings within seem to be windows service-related and were running hidden in the background. I'll add a note to the question though for others passing by! – D K Nov 8 at 22:59
0

You haven't said HOW you are "attempting to connect" or what YOU actually did.

Raspbian comes with RealVNC installed and you should be able to connect with RealVNC viewer on most platforms.

NOTE RealVNC, TightVNC and rdp are all VNC servers, but are incompatible and mutually exclusive.

Again you can ssh to the Pi from most platforms, but ssh is not enabled by default, and needs to be enabled (this is a security measure).

Many people seem to have problems with ssh on Windows 10, but this is NOT a Pi problem

Samba is relatively easy to setup and is Windows compatible.

See https://www.raspberrypi.org/documentation/remote-access/ for instruction on setting up any of a dozen methods.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.