2

I'm trying to use the built-in wifi on my pi. I upgraded the OS on my Raspberry pi 3 B from Jessie to Buster. Since the upgrade, I haven't been able to ping my pi. I noticed that ip link showed wlan0 as DORMANT so I turned off power management using iwconfig. However, while iwconfig is showing that power management is off right now, ip link is still showing that wlan0 is dormant. dmesg also confirms on reboot that power management is disabled.

On the Pi, I have internet access and can ping sites. What I'm attempting to do is SSH into my pi from my desktop.

Update with info from comment:
To upgrade I turned off my Pi, formatted the SD card on my desktop, and imaged the Buster image to the SD card.

Update 2: I bought a USB wireless adapter (Panda wireless N plug & play, rt2800usb). The Raspberry PI recognized it and was able to bring up the interface, but this interface was also stuck in DORMANT with the same conditions as the onboard wireless (Can ping external sites but it can't be pinged from devices on my home network). I also turned off power management for the new device (wlan1) but the link remains in DORMANT

  • "I upgraded the OS on my Raspberry pi 3 B from Jessie to Buster" i.e. you ignored the Foundation recommendations to do a fresh installation - apart from skipping Stretch! – Milliways Jan 19 at 2:11
  • @Milliways to upgrade I turned off my Pi, formatted the SD card on my desktop, and imaged the Buster image to the SD card. Would this be considered a fresh installation? If not, what steps should I have taken? – David Jan 19 at 7:09
1

Because you started with a fresh flashed Raspbian Buster image so just enable WiFi as described at Wireless connectivity from the Raspberry Pi Foundation. If this doesn't work then you should have a look at the hardware of your RasPi or at the device from which you try to connect.

| improve this answer | |
1

I fixed the issue by having the computer that I was trying to ping the pi with plug into the router directly instead of having it plugged into a network switch that was plugged into the router.

As for the device being stuck in DORMANT mode, I fixed that using the following command: ip link set wlan0 mode default

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.