1

Heyo, I use my raspberry pi zero as an rgb strip controller behind my desk, I have a simple http/php server running on it so I can change the color from my web browser, it is powered by a phone charger and also connected directly to my pc via the second usb port, and that's how it gets it's internet. Thing is, every morning I have to go into putty, log in with the default pi/raspberry username and password and type in sudo pigpiod so I can start controlling the strip online... This takes about a minute and I thought I'd just shorten it 2x by removing the login bs, tried finding any results on how and didn't have great luck, but I did find this post: How can I deactivate the login password on my Raspberry Pi? . I followed it's instructions and made sure to set those settings to no, restarted my pi and putty. And now when I try to log in putty still asks for a username, and if I type anything in at all it brings me this message: "disconnected: no supported authentication methods available (server sent: publickey)" and I can't get into my pi through putty... the equipment I used to set it up (keyboard/mouse/usb hub/ 5 adapters for all the connections) is who knows where in the attic so I'll just leave it be and live without rgb if there is no simple solution within putty >_>

  • Try writing in paragraphs – Milliways Apr 27 at 22:21
1

There is a solution to start automatically pigpio :

wget https://raw.githubusercontent.com/joan2937/pigpio/master/util/pigpiod.service
sudo cp pigpiod.service /etc/systemd/system
sudo systemctl enable pigpiod.service
sudo systemctl start pigpiod.service

So when you start your raspberry pi, pigpiod start automatically and so you don't have to connect to your raspberry pi with putty.

Hope this will help you :).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.