0

I used to work on my Rpi zero on same windows 10 laptop via both remote desktop connection and VNC viewer. There was no issue at all. Then I didn't use my RPi for few months, and after that it won't connect at all.

I am doing all the things same as I did previously, all same steps in accessing RPi wirelessly. SSh done, Wpa supplicants file correct, same OS on my SD card (Raspbian).

These details are from my windows 10 laptop, wifi/LAN details:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Qualcomm QCA9377 802.11ac Wireless Adapter
   Physical Address. . . . . . . . . : D4-6A-6A-A2-6F-83
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2402:3a80:1fda:cdb8:9493:29b0:abcb:7d26(Preferred)
   Temporary IPv6 Address. . . . . . : 2402:3a80:1fda:cdb8:e00e:13d0:1efd:156c(Preferred)
   Link-local IPv6 Address . . . . . : fe80::9493:29b0:abcb:7d26%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.43.60(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 30 June 2020 17:24:48
   Lease Expires . . . . . . . . . . : 30 June 2020 18:24:46
   Default Gateway . . . . . . . . . : fe80::d8f0:65ff:fea6:b4a%11
                                       192.168.43.187
   DHCP Server . . . . . . . . . . . : 192.168.43.187
   DHCPv6 IAID . . . . . . . . . . . : 282356330
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-21-6F-CD-76-50-9A-4C-D2-35-D6
   DNS Servers . . . . . . . . . . . : 192.168.43.187
                                       2402:3a80:1fda:cdb8::7
   NetBIOS over Tcpip. . . . . . . . : Enabled

I did find my RPi address using "advanced IP scanners" and it came out to be the same as i was using before hand: 172.20.10.2 Then I loaded details on putty.exe (even enabled X11), but that loading leads to timing out error.

the cmdline.txt is as follows: dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=9cbe82b0-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles

I used to work using VNC viewer and even using remote desktop connection, but now none is able to connect my RPi to my laptop.

I would really appreciate the help.

Thanks

  • You seem to have a mix of IP address 172.x.x.x and 192.x.x.x in your post - is this correct? If not can you please edit the post to show the correct data and put the output in a code block to simplify reading. Thanks – Andyroo Jul 2 at 10:56
  • How do you get the Details? Haven't seen that before on Raspbian. – Ingo Jul 2 at 11:40
  • Are the details in the question from your PC (looks Windows 10)? If so I cannot see how you are doing a scan on the 172 network unless the gateway at 192.168.43.187 is doing it. – Andyroo Jul 2 at 12:16
  • These details are from my windows 10 laptop, wifi/LAN details – Sukhmani Kaur Thethi Jul 2 at 13:19
  • and @Andyroo these are the exact figures I obtained from the command line of my windows 10 laptop. and regarding 172.xx.x.x that ip address i obtained from advanced ip scanner which showed me that at this ip my rpi is available. – Sukhmani Kaur Thethi Jul 2 at 13:21
1

I found my error. I was scanning for wrong ip address range in the 'advanced ip scanner'. Thank you @Andyroo , i found my answer in your reply. I'm a beginner in this, so that's why I couldn't figure out such a minute problem.

| improve this answer | |
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Jul 5 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.