0

I configured port 80 forwarded (or I think I did, at least) to my Raspberry Pi, where there's just an index.html file that says things are working. I can access it within my LAN via 192.168.0.100, which is configured to be static within the Pi and reserved in my router. I can also access it via my external IP xxx.xxx.xxx.xxx, but only within LAN. When try to connect to it using xxx.xxx.xxx.xxx from my phone on Verizon's network, it doesn't work.

What could be wrong in this kind of scenario?

UPDATE:

Hm, I've tried both http://www.whatsmyip.org and an app on my phone to scan for open ports, and 80 is definitely open. This is what I have set up. Where I have doodles in red, I've tried leaving it 0.0.0.0, 192.168.1.100, and xxx.xxx.xxx.xxx (obtained from http://www.whatsmyip.org), but none of the options makes the Pi available to the outside network.

One strange thing I noted is that if I go to http://www.whatsmyip.com (not .org), it says I'm in Virginia, even though I'm really in Southern California. Any ideas?

enter image description here

Another update: Wow, I test my connection again this morning from my Verizon phone, and it works from my phone now for some reason. I used 0.0.0.0 in the "external IP".

  • Do you know whether your ISP allows incoming connections? – Pete Kirkham Nov 16 '13 at 12:02
  • Double check the NAT rule on your router and do a port scan from one of the online port scan web site. As last resort change the port on which apache/lighttpd listen and try again. This is to work around the improbable case that your ISP blocks the port 80 for some reason. – ripat Nov 16 '13 at 12:05
  • You can probably get a (free) portscanner for your phone too and try that. – goldilocks Nov 16 '13 at 13:11
  • Pete, I don't know but 80 seems to be open when I test them using a website and an app on my phone. Is there another way to check for certain if my ISP is blocking this port? – musicliftsme Nov 16 '13 at 18:32
  • 2
    Hi laketuna. This doesn't seem like an issue specific to the Raspberry Pi. If you don't have any success finding an answer here then I can migrate your question to a more suitable SE site if you like. – Jivings Nov 16 '13 at 20:01
0

The correct forwarding configuration for me that works for is as follow.

For HTTP, port is 80; I set this identical for both internal and external columns in the picture I posted. Under the internal IP, I entered the LAN IP of my Raspberry PI, 192.168.1.100, which is reserved in the router and static. For the external IP, I left it as 0.0.0.0. I did not have to use my WAN IP anywhere.

| improve this answer | |
  • 1
    You do know you can mark your answer as a self-answer, correct? Just click the check-mark. It's okay and definitely not frowned upon. You are helping out more than yourself when you do it. You are helping out the site in general and future users to come. – RPiAwesomeness Mar 23 '14 at 17:05
0

Most ISPs block port 80 for whatever reason. Try setting your webserver (Apache or Nginx or whatever) to use a higher port number like 6666. Update your port-forwarding to forward external connection attempts on 6666 to your Pi on port 6666. Also flush your IP tables (iptables -F) or shut down IP tables altogether (/etc/init.d/iptables stop) just in case port 6666 isn't open by default. Then try it again.

HTH

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.