0

I got a big issue with my new Raspberry Pi 4 and I would like to troubleshoot it.

Basically when I plug my Raspberry to my router via ethernet nothing happens. The board doesn't get assigned an IP, neither the leds on the ethernet ports start blinking.

Now we get to the tricky part, the cable works fine with other devices, the router works fine with other devices and the board can connect directly to my laptop via ethernet and the led start blinking. I just flashed a new Raspbian distro to my SD but it didn't fix the problem.

I previously tried to set up a static IP address editing /etc/dhcpcd.conf but that didn't yield any result.

Can anyone suggest any solution or any way I can further investigate this?

2
  • 1
    There is ethtoolthat can give you information about the network card. Do you have a USB ethernet stick? That could be a workaround. Ref.: en.wikipedia.org/wiki/Ethtool Nov 17, 2020 at 13:37
  • What does ip a show? Post the output of ethtool eth0
    – Milliways
    Nov 18, 2020 at 1:17

2 Answers 2

1

Gigabit Ethernet is supported on the Pi 4 (though the max throughput speed CANNOT be reached on the Pi)as as such it needs a cable with all eight pins connected:

Cable colours and pin usage

I think you will have a cat-5 or cat-5e cable that will not have the correct lines for the Pi.

You maybe able to get this to work by setting the switch port to force a lower speed but this may not work with the Pi.

You may find a good quality cat-5e cable has to correct cabling BUT it is best to use a cat-6 cable.

You may also be able to set the speed of the port by using the ethtool from the command line. A good walk through can be found here (its for Debian but should be OK on the Pi) but I would try the following (with the Ethernet cable connected to the Pi and switch port):

sudo ethtool –s eth0 speed 100 duplex full autoneg off

Make sure that any entries for IP address etc are removed from /etc/dhcpcd.conf first - the more you let the router / switch handle first the better.

1
  • Changing the cable to a cat-6 solved the issues, thanks Nov 25, 2020 at 14:55
0

Andyroo gave a robust answer regarding ethernet hardware, but I don't think the issue lies there. I've used a variety of ethernet cables of different cats, many being over 10 years old as well, and never ran into any issues with them.

Especially because you mention that it connects just fine to your laptop via that cable. It does not appear to be an issue with the cable then, nor with the hardware of the pi itself - as it is fully connecting.

Since you've also stated that you're using a fresh install of the OS - I would also say that the issue does not lie with the Raspberry Pi OS. I would be inclined to think that the issue is with your router itself.

Firstly, I would check the status of the LED indicators on said router/pi when they are connected to see if there is in fact any communication whatsoever. If there is, then I would login to your router directly and examine if the pi is being fully recognized as a network attached device and if it is being assigned an IP address.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.