Running a freshly installed Raspberry Pi OS Desktop on a Raspberry Pi 4, I'm trying to install software using the graphical Add/Remove Software tool. For example, Visual Studio Code. After checking the tick near the code entry, I clicked OK. A popup appears that additional confirmations are needed because other software has to be changed:

enter image description here

I confirmed with Weiter (which means continue) but nothing happens. The list appears again and it seems that nothing is working on installing the software, there is no CPU/Network/IO usage.

enter image description here

This doesn't change after waiting for a few minutes. The code command is also still not avaliable.

Using sudo apt install code on the commandline works, about a minute later VS Code is avaliable using the code binary as well as in the application menu of the pixel desktop:

enter image description here

The same happens on other packages like vim: The GUI doesn't do anything, installing using the terminal works perfectly. I tried to run the Add/Remove software gui using the pi-packages command from the terminal, in hope to get some information, but I only get the following lines immediately after startup (without doing anything in the UI):

$ pi-packages

(pi-packages:5577): Gtk-CRITICAL **: 16:11:10.005: gtk_widget_get_style_context: assertion 'GTK_IS_WIDGET (widget)' failed

(pi-packages:5577): Gtk-CRITICAL **: 16:11:10.005: gtk_style_context_add_class: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed

I found this thread and changed the locales back to en_GB.UTF-8 (since they were German). After the reboot, the behaviour is still the same.

Why is the GUI not working? What's the problem?


I found the -v switch and after clicking continue, it gave me the following entry

GnomePackageKit     failed to install packages: Failed to obtain authentication.

This seems strange, I never got an authentication popup - also not behind the window. I tried to allow sudo without password in visudo with the line


Still doesn't work.

  • Try running sudo apt update in a terminal window and respond to any questions, If that succeeds you can try installing programs in the GUI again.
    – Dirk
    Commented Sep 19, 2021 at 15:32
  • @Dirk I did that: All packages are up to date. But I'm wondering why update shoud ask questions, I only remember this from upgrade. I also ran apt upgrade, which also says that everything is up2date.
    – Lion
    Commented Sep 19, 2021 at 15:51
  • There is a recent 'issue' introduced with release of Debian/Raspbian update to Bullseye. Some (not all) users had to acknowledge that Buster is now 'oldstable' during the update otherwise the process would not progress.
    – Dirk
    Commented Sep 19, 2021 at 17:57
  • I found out that this problem seems caused by using a RDP connection: xrdp was installed on the client and I used it to access the GUI from my workstation PC. After connecting the PI to a physical screen, mouse and keyboard, it shows an authentication dialog and now it works 🙈
    – Lion
    Commented Sep 19, 2021 at 18:13
  • Pls add that as an answer so that other users can solve similar problems
    – Dirk
    Commented Sep 19, 2021 at 18:49

3 Answers 3


I found out that this issue is limited to remote sessions, like done with xrdp. When using a screen with keyboard/mouse physically connected to the PI, it shows a authentication dialog. After providing my password, the installation was started.

We're curretly investigating this in a GitHub issue. As workaround, you can access your Pi physically if the GUI is a requirement for you, or alternatively use the commandline with the known commands like apt install.


I have exactly the same problem with PiPackages and it persist. I am logged from local machine (Raspberry Pi 400), and can't find any clues.

PiPackage stopped asking me for password and simply shows that it is installing software. But with no result.

In shell I can use apt and it works as it should work, without any problems. All the programs are installed properly.

Package log from graphical interface (Options -> Package log...) shows that software was installed but actually it wasn't.

Can this be related to installing and removing snapd?


I tried also reinstalling Pi-Packages and anything and found the problem - somewhat (IDK and have no clues) disabled LXPolKit auth daemon. So I enabled it again, restarted and installation software started to work again.

BTW it seems that Synaptic Package Manager is quite better, because Pi-Packages is not updated for a while and lost forever. Even their website (mentioned in "About" window) is owned by spammers.

Policykit Authentication Agent

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.