1

I am trying to setup my wireless dongle for my Pi, but it will not connect.

It is the Asus USB N10 recommended by many users. It has the drivers built into both Arch and Wheezy, but I cannot get it to connect. It will scan and display the wireless networks. I have tried to connect to unsecured networks as well as WPA encrypted networks but it won't connect.

I am using a 5V/2 Amp power source with just a keyboard, the dongle, and the Ethernet connected. I am in the CLI interface using the HDMI out. Software for connecting is wpa_supplicant for encryption and the basic wireless-tools supplied in the OSs.

In Arch when I try to connect using the command as root

ip link set wlan0 up

I get a

RTNETLINK answers: operation not permitted

In Wheezy I use the command as root

/etc/init.d/network restart

and I get

Listening on LPF/wlan0/ff:ff:ff:ff:ff:ff
Sending on   LPF/wlan0/ff:ff:ff:ff:ff:ff
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
No DHCPOFFERS received.

Thanks.

  • 3
    It would be useful if you provide some more details like how did you set up your system, what commands/applications are you using and what error messages you get. – Krzysztof Adamski Aug 28 '12 at 5:39
  • I'm guessing its a power issue. Have you tried using a powered hub? – Jivings Aug 28 '12 at 7:46
  • Hi @Ge3ng. Welcome to Stack Exchange. We need a few more details to help. How are you trying to connect for example? – Alex Chamberlain Aug 28 '12 at 8:11
  • Here's someone using the same stick alexcollins.org/blog/2012/… – John La Rooy Aug 28 '12 at 12:31
1

Try using wpa_cli to connect and see if it connects. If it does connect, then you can add the details into /etc/network/interfaces to get it to automatically connect.

Instructions for wpa_cli here - http://sirlagz.net/?p=666

| improve this answer | |
  • 1
    I'm not sure there are enough details in the question to judge whether this is a solution or not. – Alex Chamberlain Aug 28 '12 at 8:10
  • You're probably right about that. Worth a shot if he is already using a Powered Hub though. I'm going on the assumption he's tried basic troubleshooting - which I probably shouldn't have done in the first place :D – Lawrence Aug 28 '12 at 9:20
  • This didn't work I got the same results. – Ge3ng Aug 30 '12 at 14:40
  • What errors came up when you tried it with wpa_cli ? – Lawrence Sep 3 '12 at 5:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.