3

So I've installed OwnCloud on my Raspberry Pi and I'm able to use it properly on my LAN. Now the problem is when I want to access it from the WAN. I've set port forwarding [port 80 to port 80] & [port 443 to port 443] to the static local IP of my Pi. I've went to canyouseeme.org on my Pi and I've seen that port 80 and 443 are open. Although, when I type my external IP in the address bar of my browser, I get "400 Bad Request".

The problem is that in the configuration file of Apache2 on my Pi, it is set to host on "localhost port 80"

What do I have to change in the configuration file to be able to access my pi on the WAN?

Any help is greatly appreciated :)

  • What happens if you ping the port 80? Did you try with netcat to get a working low level connection? – Bex Oct 28 '14 at 8:10
  • See if your ISP isn't disallowing you to host stuff on your public IP. In my case many ports are blocked for non professional subscriptions. I worked around this by using other ports than 80 (i.e. 7777). Also note that depending on ISP you sometimes can't reach your machine from every other location. Again in my case I can't access my pi from my workplace (only through ssh on a non-standard port because my ISP blocks port 22) – Havnar Nov 27 '14 at 10:18
  • Try and access your machine from another internet connection. locolhost:80 is ok for server behind NAT. But sometimes NAT prevents WAN IP from inside lookup. Some have a feature to enable it other don't. – Piotr Kula Nov 27 '14 at 19:13
1

Apache let's you define a default server, which should get you around the mismatch in the server alias.

Also have you tired externally? My router's DNS would not allow me to connect using my dnsdynamic address from the LAN but it would from the internet. I overcame the issue by adding a host entry to my local computers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.