4

I'm using an pc display with an DVI-port connected to the HDMI port of the pi. For power-saving reasons, I'd like to switch off/on the display via ssh. Using tvservice -o, my display is perfectly switching off. But the display won't turn on again.

I've tried:

  • tvservice -p
  • tvservice -e(with all supported modes according to tvservice -M)

In any case, the backlight of the screen turns on (and remains in this state), and that's it. No desktop. Also, nothing to see via VNC, so I'll have to reboot.

What's going wrong here? I'm running NOOBS (Linux raspberrypi 3.18.7+ #755).

  • 1
    Is it possible that your monitor has a power saving mode of its own, that powers down the monitor after a certain time if it has no input signal? – Bex Feb 26 '15 at 13:36
  • Yeah, if there has not been any activity on the desktop after a while the Xorg server (the basis of the GUI) blanks the screen. Plug in a mouse and jiggle it and see if that wakes it up. If so, there's some command to wake X and/or it can be configured to not do this; you're probably best off asking about that on Unix & Linux. If you do figure it out, please post an answer to your own question. – goldilocks Feb 26 '15 at 15:05
  • @Bex Yea, when there is no input signal, the monitor goes to standby, just like nearly every monitor does. But when the signal signal comes back, it should turn on again (which is the case for the backlight, but not the actual screen content). I've tested two monitors - same problem. – jp-jee Feb 26 '15 at 17:55
1

The Xorg server, which is the foundation of the GUI, blanks the screen after a period of inactivity. You can find out how long this is via xset q (the "timeout" value under "Screen Saver"). It is probably 600 (10 minutes).

The display will wake up if you hit a keyboard key or jiggle a mouse associated with the session.

You can prevent this behavior with:

xset s noblank

According to man xset this will "display a pattern rather than blank the video"; however, on modern systems real screen savers aren't necessary or used anymore and what will most likely happen is just nothing (i.e., the screen won't blank). You can test what will actually happen with xset activate.

Alternately, you could just set the timeout value; it seems to have a maximum of 20864 (a little under 6 hours).

xset s 100000

Should leave you with that maximum. xset s off leaves the timeout as 0, so you could try that too (or just xset s off...).

  • 1
    I've already disabled the screen blanking. However, even mouse or keyboard events do not change anything. – jp-jee Feb 26 '15 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.