1

I changed my bash prompt text to just the "π" sign. I really want to change it back to the default but I don't want to reset the WHOLE Pi. I've been looking around on this site and I can't find anything. The linux command I got from http://www.cyberciti.biz/tips/howto-linux-unix-bash-shell-setup-prompt.html doesn't work either. Is there a way to edit /.bash_profile so I can get the default back. Thanks.(I'm running raspbian by the way) I tried to run:

pi $ sudo grep -d skip "PS1" /home/pi

But it just returned:

pi $ 
4
  • How did you change it? what file did you edit? You may not have a ~/.bash_profile but a ~/.bashrc file instead. Sep 24, 2015 at 4:44
  • 1
    Could you edit your question and paste the output of the following command sudo grep -d skip "PS1" /home/pi/.*
    – joan
    Sep 24, 2015 at 8:06
  • Steve Robillard , I made a ~/.bash_profile file as directed on codecademy.com/en/courses/learn-the-command-line then changed prompt as directed on www.cyberciti.biz/tips/howto-linux-unix-bash-shell-setup-prompt.html Sep 24, 2015 at 20:40
  • @BradenParks The command was sudo grep -d skip "PS1" /home/pi/.* (notice the /.* after /home/pi).
    – joan
    Sep 25, 2015 at 21:53

2 Answers 2

3

If you just want to get back the default, you can copy the default configuration files from /etc/skel.

% ls -a /etc/skel
.  ..  .bash_logout  .bashrc  .profile
0
2

You can just change the prompt by setting variable PS1.

export PS1="pi $ "

for example, for the shell you're in. But more generally, just change whatever edit you made to set the prompt to π in the first place?

1
  • That doesn't work it just changes it to "pi $" not to the default setting. Sep 24, 2015 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.