1

How do I setup my C-Berry 5" TFT Screen from Admatec, with my Raspberry Pi 2 Model B? Distro: Raspbian Jessie 2015-11-21

Tried:

wget http://www.airspayce.com/mikem/bcm2835/bcm2835-1.46.tar.gz 
tar zxvf bcm2835-1.xx.tar.gz
cd bcm2835-1.xx
./configure
make
sudo make check
sudo make install

Made sure SPI and I2C are off in raspi-config and Tree is on.

wget http://admatec.de/sites/default/files/downloads/C-Berry.tar.gz
tar zxvf C-Berry.tar.gz
cd /C-Berry/SW/tft_test
make
sudo ./tft_test

Instructions: https://www.elfa.se/Web/Downloads/_t/d/C-BERRY_eng_tds.pdf?mime=application%2Fpdf

BR Chris

0
1

So, the short answer.... for god's sake look at the connecting cable between screen and TFT add-on card. Blueish color facing down not up.

Full stepvise instruction:

Install latest Raspberian distro (in this case Raspbian Jessie 2015-11-21 - 4.1.13-v7+ #826)

Have all the latest by:

sudo apt-get update
sudo apt-get upgrade

Then download and unpack BCM2835 package:

cd Downloads
wget http://www.airspayce.com/mikem/bcm2835/bcm2835-1.48.tar.gz
tar zxvf bcm2835-1.48.tar.gz

Adjust the bcm2835.h to RPi2 settings (how I did):

sudo nano bcm2835-1.48/src/bcm2835.h

Change row defining:

#define BCM2835_PERI_BASE               0x20000000

TO:

#define BCM2835_PERI_BASE               0x3F000000

Compile the library:

cd bcm2835-1.48
./configure
make
sudo make check
sudo make install

In order for bcm2835 library SPI to work, you may need to disable the SPI kernel module using:

  • sudo raspi-config
  • under Advanced Options - enable Device Tree under
  • Advanced Options - disable SPI
  • Reboot.

Then first run your first try with screen developers software:

cd Download
wget http://admatec.de/sites/default/files/downloads/C-Berry.tar.gz
tar zxvf C-Berry.tar.gz
cd C-Berry/SW/tft_test
make
sudo ./tft_test

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.