1

I should probably say up front the I'm not doing this to actually fill a need. I'm doing this because I saw other threads on other forums for doing this so I wanted to learn a little just using some spare parts.

I have it to were one usb wifi adapter is connected to my network and the other (via a powered usb hub) is actually broadcasting it's ssid. But I have run into 2 problems I don't know enough to even know where to start.

(1) The 2nd adapter (broadcasting the new ssid - the "extender") does not show the correct IP address. I set it up to be 192.168.42.2 (in the interfaces file), but it is showing an IP address in the 268.xxx.xxx.xxx.

(2) when I try to connect to the "extender network", it asks for the WPA password but never connects. If I have start hostapd via command line via /usr/sbin/hostapd /etc/hostapd/hostapd.conf I can then see any messages output by hostapd. If kicks out 2 messages about WPA and then just seems to loop on that - 2 messages, a few seconds later the same 2 messages, et al. I don't know what to do with that as hostapd does have the WPA setup including the passphrase.

Any help would be appreciated.

UPDATE

Ok, for some reason things have changed a little. The below is the screen from when I started hostapd, and the entries with STA in them are what showed up when I tried to connect from my laptop. It seems to indicate that everything went ok, yet the connection attempt on my laptop just says "checking network requirements", never connects and then eventually times out.

pi@raspberrypi:~ $ sudo /usr/sbin/hostapd /etc/hostapd/hostapd.conf
Configuration file: /etc/hostapd/hostapd.conf 
Using interface wlan1 with hwaddr 00:1a:ef:4c:e9:c6 and ssid "fargojoext" 
wlan1: interface state UNINITIALIZED->ENABLED 
wlan1: AP-ENABLED 
wlan1: STA ac:d1:b8:65:45:56 IEEE 802.11: authenticated 
wlan1: STA ac:d1:b8:65:45:56 IEEE 802.11: associated (aid 1) 
wlan1: AP-STA-CONNECTED ac:d1:b8:65:45:56 
wlan1: STA ac:d1:b8:65:45:56 RADIUS: starting accounting session 56EA4995-00000000 
wlan1: STA ac:d1:b8:65:45:56 WPA: pairwise key handshake completed (RSN)
-1

You need a repeater mode, take a look at this guide - it seems to do exactly what you want

  • Link only answers are bad, as the odds are that your intended destination will, sooner or later, cease to exist/move/be edited/etc. Can you summarise the key points of the linked reference in your answer? – goobering Mar 17 '16 at 15:04
  • @goobering, plagiarising a source is a BAD practice, so I didn't plagiarised it, but referred to. Can you please take a look at the source linked instead of posting a standatd cliche phrase that makes NO SENSE in this particular case? – Alexey Vesnin Mar 17 '16 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.