I just installed motion on my Raspberry Pi 3 with the Raspbian distro, the software seems to work fine. However, I can't see any image from the local camera. I checked the log of motion and this is the content:

enter image description here

this is the result that I get in motioneye:

enter image description here

I don't know how to solve the issue, someone could help me please?


  • 2
    You should indicate what exactly the "local camera" refers to.
    – goldilocks
    Commented Jan 24, 2017 at 19:09
  • @goldilocks local camera is this device: /dev/v4l/by-id/usb-Pixart_Imaging_Inc._CIF_Single_Chip-video-index0
    – AgainMe
    Commented Jan 25, 2017 at 13:33

3 Answers 3


A short Google search for Device doesn't support VIDIOC_G_STD gave these two links:

The first page suggests:

  • Check for ls /dev/video*, no output means your camera is not connected properly or driver is missing

  • If a camera is recognized, tweak some config files

  • If not, give the older Raspbian Wheezy a try, it was reported to work much better than the newer Jessie.

The second one (GitHub issue) concludes that the camera is simply not compatible, so try with another one.

Hope this helps and good luck in resolving this issue!

  • 1
    Hello, when I type ls /dev/video* I get: /dev/video0 so this should indicate that the device is correctly connected. I don't understood the point two where you said tweak some config files, which config files? And I can't format the raspberry, I've too much things installed.. Thanks.
    – AgainMe
    Commented Jan 25, 2017 at 13:32
  • Have you even read the pages? The second post on the first one says: Try adding this line to the bottom of your /etc/motion.conf (I haven't tested this): input -1 Then restart motion with sudo service motion restart
    – linusg
    Commented Jan 25, 2017 at 13:39
  • yes, I've added this line but same error message, the camera device is however this: /dev/v4l/by-id/usb-Pixart_Imaging_Inc._CIF_Single_Chip-video‌​-index0
    – AgainMe
    Commented Jan 25, 2017 at 13:48
  • Then read the whole thread there, or get another SD card and test with Wheezy. Jessie was reported to have issues with some software several times where it worked like a charm previously.
    – linusg
    Commented Jan 25, 2017 at 13:49
  • I just reinstalled motion, actually seems that if I go into I can see the interface of motion (with the same problem of gray camera screen), but if I access to motioneye typing: I get this error: ERR_CONNECTION_REFUSED, why happen this?
    – AgainMe
    Commented Jan 25, 2017 at 18:01

Try this: sudo modprobe bcm2835-v4l2

if works then put above line in /etc/rc.local to run this at boot time.

  • 2
    It worked for me, but it'd be great with some explanations.
    – Anthony
    Commented Apr 3, 2018 at 9:26
  • worked for me too, but agreed with @AnthonyB .. why does it work ?
    – bart s
    Commented Aug 8, 2018 at 20:18
  • This should be comment, not answer. @AnthonyB modprobe bcm2835-v4l2 is installing/loding module bcm2835-v4l2 which is required to run the camera.
    – amrx
    Commented Feb 8, 2020 at 22:32
  • @amrx I know it today but I didn't know it 3 years ago. Thank you for this comment, should have been explained with the answer.
    – Anthony
    Commented Feb 11, 2020 at 12:50
  • cant seem to access the rc.local folder
    – A.Rowan
    Commented Aug 4, 2020 at 1:58

If you are using USB camera, then uninstall the RPI web interface and then install fswebcam and ffmpeg and then start the motion.

Hope it does work!

Thanks, Kavi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.