0

I still get access denied massage when I try to login with putty even with file named "SSH" in boot partition.enter image description here enter image description here

  • If it's really the Pi then the SSH daemon is working, so the ssh file-configuration worked. You need to provide the correct password or ...connect to the correct machine. It would be pretty unusual (although not impossible) for a router with default configuration to give .1 address to the client machine. – techraf Jan 27 '17 at 13:42
  • That you're getting as far as that response screen means that you're connecting to something at that IP address. I notice that 192.168.2.1 seems to be the default address assigned to Belkin routers - is it possible you're trying to connect to your router rather than the Pi? – goobering Jan 27 '17 at 14:00
  • 2
    I agree, seems you're connecting to your router's SSH server. Try connecting to the router (web UI if it has one) and find a list of known machines (or DHCP log) and see what IP's are actively used right now. You can probably pinpoint the Pi pretty quick (default hostname is raspberrypi I think). If you don't have access to the router, install nmap and run nmap 192.168.2.0/24 to scan the entire class-c. It should run multiple checks (ping, basic port scan, and I think attempt OS identification). It should tell you pretty quick which IP your Pi is sitting on. – Adam Plocher Jan 27 '17 at 14:13
3

It's already working since you can connect to it. Putty would give a connection refused error otherwise.

In this case, make sure you typed the password correctly. If you did not change it, the password should be raspberry. Another possibility would be you're connected to the wrong machine.

0
  1. make sure you used the up-to-date image to install from, the ssh file option is new.
  2. if you are in an environment where other raspberry pi can be connected (company network), make sure you are connecting to you own raspberry pi. A few weeks ago I thought setting up my raspi and realized too late that I completely screwed another departmens Dashboard ;-) they just used the standards without bothering to change the password or hostname... See next step.
  3. Did you already log into your pi lets say with a monitor and keyboard or alternatively with console cable / COM port? If you can do that, than it would make sense to change your hostname from raspberrypi.local to something else. If your network / device uses bonjour/zeroconf you could ping your device with the new hostname you just created. This way you can be sure your are addressing the correct device.
  4. if you are logged in use raspi-config and check again that SSH is enabled.

In short: I believe you either trying to log into the wrong device, or have the wrong password, or both.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.