0

I am observing this peculiar behavior of my usb mouse with Raspberry Pi 3. I am able to move the cursor but right and left click does not work. Even cursor hovering over icon does not highlight particular item. if i unplugged mouse and re-insert, it works for sometime and then same behavior again.

I am using 5V 2.5A power adaptor, so I don't think its a power issue.

Could you help resolving this issue. I am using latest raspbain Jessie OS dated 10 April 2017.

Regards, Lalit

  • Have you tried another mouse? What model mouse do you have? How is it connected to the Pi? If wireless is it Bluetooth? Just because your power supply says 2.5 amps on the label that does not mean that is what the board is seeing. If only some mouse functions fail, while others work as correctly, I would guess a defective mouse or dongle. – Steve Robillard May 31 '17 at 17:19
  • Its any wired usb mouse. I have faced same issue with wireless(BT) mouse also. – Lalit Saraswat Jun 1 '17 at 1:22
  • Given that you have observed this behaviour with two different mice. I would investigate power issues first, by actualling measuring the voltage at the board. – Steve Robillard Jun 1 '17 at 2:06
0

It's possible you have a defective USB Mouse. If you have access to another USB mouse you could try plugging that in, power up the pi, and try using it.

You may also want to try an alternate USB port.

Finally if you are still having issues but can manage to enable VNC/SSH you can remote in long enough to pair a bluetooth device.

Hopefully this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.