HW: Raspberry Pi 3, 16 gig hard drive

Relevant Output:

Starting dhcpcd on all interfaces...
Starting LSB: Autogenerate and use a swap file 
Starting LSB: Switch to ondemand cpu governor(unless shift key is pressed).. 


If I don't press shift on time my Raspberry Pi constantly resets itself. I used the Raspbian configured openhabian ISO image but my understanding is that this issue is part of Raspbian boot. SSH connection is not possible.

Otherwise image works fine.

  • 2
    We are experiencing the same issue--all of a sudden--with a CM3 module. I don't believe we are on the latest updated version, but definitely Stretch.
    – Beez
    Jul 25, 2019 at 18:55

1 Answer 1


My raspberry pi has also suddenly starting going into a restart loop due to this.

I'm not sure why switching to the ondemand cpu governor causes a problem, but I've disabled it for now following instructions in this post: How to change the default governor?

You can do this by disabling the raspi-config service which, for me, didn't do anything other than switch to the ondemand cpu governor. Here's how:

sudo systemctl disable raspi-config


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.