0

I have run a Pi 3B successfully using a KVM switch sharing keyboard, mouse and VGA monitor (with a HDMI-VGA adapter on the Pi) with a desktop PC. Now that I have moved on to a Pi 4B, I find that with the same KVM switch pointing at the Pi, the Pi fails to start until I point the switch to the desktop PC and back to the Pi. While this is hardly an onerous task, it is annoying. Is there any way to fix things so that the Pi 4B will start without this switching to and fro?

1

Not knowing the capabilities of the monitor, the hdmi_mode below is probably wrong (82 is 1920x1080 resolution)

However, this should get you working

In the config.txt file in the boot partition, add the following settings

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=82

other values for mode can be found at https://www.raspberrypi.org/documentation/configuration/config-txt/video.md under the part where it says These values are valid if hdmi_group=2 (DMT):

Some notes:

hdmi_group

The hdmi_group command defines the HDMI output group to be either CEA (Consumer Electronics Association, the standard typically used by TVs) or DMT (Display Monitor Timings, the standard typically used by monitors). This setting should be used in conjunction with hdmi_mode.

hdmi_group=0 for Autodetect
hdmi_group=1 for CEA
hdmi_group=2 for DMT

hdmi_force_hotplug

Setting hdmi_force_hotplug to 1 pretends that the HDMI hotplug signal is asserted, so it appears that a HDMI display is attached. In other words, HDMI output mode will be used, even if no HDMI monitor is detected.

You may also add

hdmi_force_mode=1

hdmi_force_mode

Setting to 1 will remove all other modes except the ones specified by hdmi_mode and hdmi_group from the internal list, meaning they will not appear in any enumerated lists of modes. This option may help if a display seems to be ignoring the hdmi_mode and hdmi_group settings.

You may also need to play with overscan settings (as per linked page), again, this depends on your monitor

| improve this answer | |
  • I've tried the edits you suggested, without success. The monitor is Acer P195HQL 1360x768px so I am using mode 39 (1360x768 60Hz) The Pi still hangs without any yellow led activity until I have switched the KVM switch away from the it to the PC, after which I have to switch it back to get the Pi screen on the monitor. – Peter N Aug 31 '19 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.