2

As I'd like to play MP3 files on my Raspi 3B, I installed mpg123 together with the libmpg123-dev package so that I can call mpg123 from some host application. However, every time I call out123_open (), I get seven identical error messages, which read as follows:

[src/libout123/module.c:163] error: API version of module does not match (got 1, expected 2).

A brief look into the out123.h header file revealed 2 as the current API version. I've got libmpg123-dev from the sid branch, as the version from the stable branch lacks the out123 files I need.

What's wrong here? Thank you for any useful hints.

  • Is the right header being pulled by your compiler? If you're using gcc, try gcc -H -fsyntax-only <yourfile.c> which will output the headers used, and edit that in your post if you can. – Aurora0001 Jan 20 '18 at 18:26
  • OK, I've got a result: . /usr/include/mpg123.h .. /usr/include/fmt123.h . /usr/include/out123.h …which is basically what I expected. – Neppomuk Jan 20 '18 at 21:39
  • 1
    Hmm, odd. That sounds okay, but it definitely seems like your install has mixed up an older version or something. If you're running out of other options, the only idea I can suggest is the 'nuclear option' of trying a fresh OS image and installing libmpg123 again. Hopefully, though, you find a better solution. – Aurora0001 Jan 21 '18 at 10:13
  • I strongly hope I'll find a more viable solution than re-installing everything. Supposedly, the DEB packages of mpg123 are full of bugs: The libmpg123-dev package from the stable branch lacked out123.h, so I had to take the package from the sid (= unstable) branch, yet this one isn't working wither. I've also left a support request on the mpg123 mailing list, but nobody has responded so far. – Neppomuk Jan 21 '18 at 17:13
1

At least I've now got a workaround now: I got the sourcecode tarball from Github and compiled it myself. I know this isn't a very clean approach (especially not on production systems), but at least I've got a working mpg123 installation now.

| improve this answer | |
  • 1
    Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Feb 26 at 9:45
  • Well, I've been hoping for a "real" solution, not just for a workaround. – Neppomuk Feb 26 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.