1

My Rspberry Pi 3 Model B+ has the SD card with the latest Raspbian lite OS. I connect it via the USB port of my Mac for the power supply and the Ethernet cable is connected to my Windows machine.

I can see the green light flashes for a while and then it goes off after say 20 seconds. I then see a constant red light. I then open putty on my Windows and try to ssh into the Pi. I also have an empty ssh file under the boot directory. When I now try to boot into the pi using putty, I get the following message:

Unable to open connection to raspberrypi.local Host does not exist

I even tried to just give raspberrypi instead of the raspberrypi.local, but nothing seems to work.

I tried to ping raspberrypi.local and raspberrypi, but nothing seems to work. I get a Host not found message back.

Any ideas as to what is wrong with this? How can I resolve this?

EDIT: I solved it. The problem was that my Windows laptop was not setting up any network with the Pi even though I had a LAN cable connected to the Pi from my Windows machine. My Windows laptop is connected to the home internet via WiFi.

Now, I connected the Pi directly on the router at my home and bang I can see the pi listed in the set of devices at my home and thus I was able to log in!

QUESTION:

My router is in the cellar, how can I now just use my Mac to give the Pi the needed internet connection? I don't want to go to the cellar every time I want to play with my Pi. Any ideas as to how I can make the Pi connect to the internet just using my Mac?

  • can you try using the IP address set on the pi? – eftshift0 Apr 21 '18 at 6:19
  • If you setup Internet Connection Sharing on the Mac and plug in Ethernet cable it will work, but WHY NOT just connect the Pi3 WiFi to your network. PS I don't know which Mac, BUT trying to power a Pi from USB will cause problems; I am surprised it works at all! – Milliways Apr 21 '18 at 6:52
  • pardon the correction, but that depends on the USB... new MacBooks will source 5 amps from the USB C port. And IIRC, the USB 3.1 spec calls for 5 amps. – Seamus Apr 21 '18 at 12:07
3

If I understand correctly, your RPi is connected to your WiFi router downstairs via Ethernet patch cable. If that's the case, then your RPi should already have an Internet connection, and your Mac has nothing to do with that!

In any case, here's how you check that:

  1. ssh to your RPi
  2. from your command line in your RPi, enter ping -c 3 www.google.com
  3. if your pings get a response; you're connected!

If you don't get a response, ask yourself these questions:

  1. Is my RPi configured to use DHCP? (if not, fix this, or alternatively: properly configure a static IP address in RPi and your WiFi router)
  2. Is my WiFi router properly configured to allow the RPi to "join" the network; e.g. it's acting as DHCP server and router, no MAC address blocking, etc.

If you still have issues, post details here and we'll help you sort it.

  • 1
    You can differentiate the a lack of connection from a lack of DNS service by using an IP address (e.g., 8.8.8.8) with ping as well (you can also tell by the error message, but the easiest way to learn that is to infer it by trying both). – goldilocks Apr 21 '18 at 12:36
  • That's correct, but if he used the ip address, then we wouldn't know if his dhcp service was configured properly (i.e. supplies a DNS), and so there may still be other issues to smoke out . :) – Seamus Apr 21 '18 at 13:57
  • Hence "by using an IP address with ping as well". ;) – goldilocks Apr 21 '18 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.