0

First of all I read a lot of thread about problems with connections but all referred to a Wi-Fi LAN adapter. My problem is on the eth0 LAN port.

I have a Raspberry Pi 2 Model B with the latest stable Raspbian installed. I use it as a DHCP server so I configured a static IP. The problem is: after a reboot, the LAN port seems disabled. No ping, ssh or VNC work. But if I connect via real VNC over the cloud I can access the RPi and immediately after connected eth0 starts and i can ping or access ssh.

It seems the LAN port wakes up after an external input.

But after some minutes after disconnect from VNC again the LAN port goes to sleep.

This is my /etc/network/interfaces:

iface eth0 inet static
        address 192.168.3.91
        netmask 255.255.255.0
        broadcast 192.168.3.255
        network 192.168.3.0
        mtu 1500
        gateway 192.168.3.1

And this is my /etc/dhcpcd.conf:

interface eth0
static ip_address=192.168.3.91
static routers=192.168.3.1
static domain_name_servers=208.67.222.222 208.67.220.220
static domain_search=

I tried with

  • auto eth0
  • inet manual (instead static)
  • using a script executed on boot with sudo ifup eth0

but nothing worked...

On boot, the LAN port is not responding to pings.

  • 1
    I don't know anything about your network but this looks like an issue with arp reply. Connecting from the cloud (what ever this is) your pc get an arp reply from the pi 2 so the pc knows its mac address and stores it the arp cache. Without refresh the entry will be deleted after 300 sec by default. If you connect through your local network where arp reply does not work connection will work for max. 300 sec (without refresh from cloud connection). Mabye ... Is there any firewall? – Ingo Apr 21 '18 at 11:09
  • 1
    You don't identify what OS exactly but do you think your problem might have something to do with ignoring the warning # Please note that this file is written to be used with dhcpcd # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf' Unless you specify what you did no one can tell. Also your dhcpcd settings are wrong. – Milliways Apr 21 '18 at 11:13
  • @Ingo: no firewall – Simone Bissi Apr 21 '18 at 14:41
  • @Milliways: I followed tuts like this [raspberrypi.stackexchange.com/questions/37920/… where I can use both interfaces or dhcpcd.conf but still same problem. Connection goes up and down without reason. – Simone Bissi Apr 21 '18 at 14:43
  • Could it be problem with power supply? I'm using a phone charger with 5.0V and 550mA. – Simone Bissi Apr 21 '18 at 14:45
0

Solved the problem. My RPi was setted up correctly. The real problem was on LAN. There was another linux router with some network services still active that make conflicts with RPi. I supposed i stopped all network services on that machine but i was wrong. Without that machine on LAN, RPi working perfectly. Thanks to all for help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.