0

I am getting errors about “DNS address” could not be found ERR_NAME_NOT_RESOLVED when going to SOME web pages (like doing a duckduckgo search) yet I can go to google and do searches, and raspberrypi.org works fine (unless trying to search the site. Search results from Google randomly seem to work or not.

Based on this thread https://www.raspberrypi.org/forums/viewtopic.php?p=469583 and jumping around a few others here is what I have tried.

I am using the latest version of Raspbian Full on a Pi 3

I have Google Fiber and have tried connecting it with wi-fi or ethernet, same issue. When connected by wi-fi, Google Fiber shows the pi’s name (raspberrypi) and I set static ip to 169.254.68.136

I tried enabling a DNS server to 136.62.136.72, though I am still hazy about how DNS works. same behavior. One post recommends adding “dns-nameservers 8.8.4.4 8.8.8.8” to /etc/network/interfaces. same behavior.

I also tried https://www.howtogeek.com/167190/how-and-why-to-assign-the-.local-domain-to-your-raspberry-pi/ to assign a local domain to my pi, but that hasn’t seemed to do anything; raspberrypi.local gets the DNS error.

Any ideas on what the heck is going on?

here's the detailed info based on one of those posts:

Post the output from the following commands:

ifconfig -a

route

cat /etc/network/interfaces

root@raspberrypi:/home/pi# ifconfig -a

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
    ether b8:27:eb:c6:ae:a0  txqueuelen 1000  (Ethernet)
    RX packets 4914  bytes 1892923 (1.8 MiB)
    RX errors 0  dropped 1  overruns 0  frame 0
    TX packets 1058  bytes 158075 (154.3 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    inet6 ::1  prefixlen 128  scopeid 0x10<host>
    loop  txqueuelen 1  (Local Loopback)
    RX packets 9  bytes 524 (524.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 9  bytes 524 (524.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet6 2605:a601:4044:8600:1726:a088:f043:1d8f  prefixlen 64  scopeid 
0x0<global>
    inet6 fe80::a37b:1a59:83e9:4628  prefixlen 64  scopeid 0x20<link>
    ether b8:27:eb:93:fb:f5  txqueuelen 1000  (Ethernet)
    RX packets 133541  bytes 188543020 (179.8 MiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 98870  bytes 11444959 (10.9 MiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
**root@raspberrypi:/home/pi# route**
  Kernel IP routing table
  Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

root@raspberrypi:/home/pi# cat /etc/network/interfaces

 # interfaces(5) file used by ifup(8) and ifdown(8)
 # Please note that this file is written to be used with dhcpcd
 # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'
 # Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
dns-nameservers 8.8.4.4 8.8.8.8

And on your Windows machine (that you're using to post on here): ipconfig /all:

Windows IP Configuration
   Host Name . . . . . . . . . . . . : Flipper-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
   Physical Address. . . . . . . . . : 08-9E-01-EB-5C-93
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter PdaNet Broadband Connection:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : PdaNet Broadband Adapter
   Physical Address. . . . . . . . . : 02-50-F2-7D-1D-92
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 12:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : 0C-8B-FD-66-F4-05
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 2:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Hosted Network Virtual Adapter
   Physical Address. . . . . . . . . : 0E-8B-FD-66-F4-04
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Wireless-N 7260
   Physical Address. . . . . . . . . : 0C-8B-FD-66-F4-04
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . :         2605:a601:4044:8600:1884:c303:f3b0:b20c(Preferred)
   Temporary IPv6 Address. . . . . . : 2605:a601:4044:8600:9ca6:98a0:540d:3bef(Preferred)
   Link-local IPv6 Address . . . . . : fe80::1884:c303:f3b0:b20c%17(Preferred)
   IPv4 Address. . . . . . . . . . . : 169.254.68.147(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Thursday, May 17, 2018 6:10:08 PM
   Lease Expires . . . . . . . . . . : Friday, May 18, 2018 7:45:45 PM
   Default Gateway . . . . . . . . . : fe80::f6f5:e8ff:fe6e:cb30%17
                                   169.254.68.1
   DHCP Server . . . . . . . . . . . : 169.254.68.1
   DHCPv6 IAID . . . . . . . . . . . : 319589373
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-CF-CC-BA-08-9E-01-EB-5C-93
   DNS Servers . . . . . . . . . . . : 2605:a601:4048:2b00::1
                                   169.254.68.1
   Primary WINS Server . . . . . . . : 169.254.68.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Local Area Connection* 6:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #3
   Physical Address. . . . . . . . . : 0E-8B-FD-66-F4-05
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a040:bd23:a804:b312%19(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.179.18(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 537824253
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-CF-CC-BA-08-9E-01-EB-5C-93
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                   fec0:0:0:ffff::2%1
                                   fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 14:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
  • "static ip to 169.254.68.136" this is NOT a static address it is Link-local address WHY are you fiddling with /etc/network/interfaces? DNS is normall set by your router. – Milliways May 18 '18 at 3:36
  • it is a reserved ip address, set on fiber's device configuration IPv4 address 169.254.68.136 (reserved) MAC address b8:27:eb:93:fb:f5 I only started fiddling with /etc/network/interfaces because of other posts about DNS, the error hasn't changed – quentinfool May 18 '18 at 3:41
  • "Any ideas on what the heck is going on"? 1) Whatever links that you are referring to go date back to 2013, it probably no longer valid or obsoleted as Debian/Raspbian has evolved since then. 2) Stop messing around etc/network/interfaces, and restore it to original before your changing; 3) Reboot your system and if problem persist, edit your post to describe the problem and take out the irrelevant information, and show your ifconfig, route results, and maybe your router settings (on dhcp and dns). – hcheung May 18 '18 at 4:16
  • Please show us the full configuration files used for your DNS server. – NomadMaker May 18 '18 at 7:23
0

There are many things mixed up and unclear. I will guess and try to sort it out. I assume you have this configuration:

IPv6-Addr*                      |Range 169.254.68.129
RPI ~.~.~.~.~.~.~.~.~.~.~\      \   to 169.254.68.254
           wifi           ROUTER/DHCP-SERVER ----wan----> Google Fiber | High Speed Internet Service & TV
MSWIN ~.~.~.~.~.~.~.~.~.~/              136.62.136.72
169.254.68.147    169.254.68.1

* IPv6-Addr. for RPi = 2605:a601:4044:8600:1726:a088:f043:1d8f
  • The local network has the subnet 169.254.68.0/24
  • There is a router with 169.254.68.1 as default gateway
  • There is a DHCP server (169.254.68.1) on this subnet for its ip addresses
  • There is a DNS server with ip address 169.254.68.1
  • The raspi has no IPv4 address only IPv6 addresses, but send and receive data
  • There are no entries in the routing table

This cannot work

Seems the local network is manual configured with subnet 169.254.68.0/24, complete with DHCP- and DNS server. This isn't allowed because the address range 169.254.0.0/16 is reserved for Link-local addresses. There its said:

In a computer network, a link-local address is a network address that is valid only for communications within the network segment (link) or the broadcast domain that the host is connected to. Link-local addresses are not guaranteed to be unique beyond a single network segment. Routers therefore do not forward packets with link-local addresses.

By definition devices do not assign itself a link-local address if there is a DHCP server on the subnet but the addresses they are offered from the DHCP server are link-local addresses ... That conflicts. This may be the reason why the raspi only uses IPv6 addresses.

So we have a mixed IPv4 / IPv6 communication. We have to decide what to use. This setup is for IPv4.

There must be entries in the routing table. After clean up the configuration check with ip route.

You should delete the entry in /etc/network/interfaces for a DNS server and reconfigure your complete local network with a subnet reserved for private networks. These are 10.0.0.0/8, 172.16.0.0/12 and 192.168.0.0/16. I suggest to use 192.168.1.0/24 so your network will look similar to this:

192.168.1.129                   |Range 192.168.1.129
RPI ~.~.~.~.~.~.~.~.~.~.~\      \   to 192.168.1.254
           wifi           ROUTER/DHCP-SERVER ----wan----> Google Fiber | High Speed Internet Service & TV
MSWIN ~.~.~.~.~.~.~.~.~.~/              136.62.136.72
192.168.1.130    192.168.1.1(fix)

DHCP server = 192.168.1.1
DNS  server = 192.168.1.1
  • Changing my router and pi ip addresses to the 192.168.1.0/24 made it work (so far no usual DNS errors popping up) I had switched over to the 169 addresses previously when i first started to ssh into the pi before i got a seperate monitor. – quentinfool May 21 '18 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.