I am using Raspberry Pi for the first time. I did the conventional setup that most people mentioned. This includes

1.Flashing Raspbian onto a SD card

  1. Edit Config/cmdline files and add an ssh file (without an extension)

  2. Download Bonjour

  3. Load SD Card into the Raspberry Pi

  4. Connect via USB and SSH host raspberry.local

The result is the error that the connection does not exist. I tried pinging from cmd but I got the same result.

I am not sure what the error could be. Something interesting I noticed is that the ssh file keeps disappearing after I boot up the raspberry pi. Is this normal?

  • Are you plugged into the correct µUSB port? Only the one closer to the center of the board works for this. Commented Sep 26, 2018 at 15:06
  • What do you do with the downloaded Bonjour? Raspbian uses avahi for auto configuring network and has it installed by default. Where is the RasPi connected? To a Laptop? Is there a DHCP server running on the network?
    – Ingo
    Commented Sep 26, 2018 at 16:06

5 Answers 5


I have crawled a lot of forums with the solution below. The main issue encountered in Windows 10 is that, the raspi zero maybe identified as USB COM port device. We have to install a RNDIS driver instead of the auto-installed USB serial port driver.

  1. Download RNDIS driver from here : RNDIS driver, originated from here
  • unzip the file and put them in a [folder1]
  1. Open Device Manager, scroll to Ports (COM&LPT)
  2. Do this step if you do not know which com port your raspi zero is on
  • Unplug and replug your raspi w
  1. Right click the "COM PORT X" and select “Update Driver Software”.
  • Browse my computer for driver software
  • Select the path of [folder1]
  • Install the driver
  1. After successful installation, the "com port" device will be treated as "USB Ethernet/RNDIS gadget"
  2. You can now ping raspberrypi.local
  • So is ssh, if you have completed all procedures for USB-TO-OTG

Sources from https://www.factoryforward.com/pi-zero-w-headless-setup-windows10-rndis-driver-issue-resolved


It might happen that windows has no proper mDNS client. This might cause that raspberrypi.local is not registered. You can resolve this by installing something like Bonjour.

Check the adafruit guide on zeroconf networking for further information.


You have to enable the USB Ethernet Gadget module before continue.

Here the tutorial https://cdn-learn.adafruit.com/downloads/pdf/turning-your-raspberry-pi-zero-into-a-usb-gadget.pdf


It just worked after one point. I cannot remember what exactly changed but looking back the post my assumption is that I stupidly tried to ssh into raspberry.local not raspberrypi.local.

I also had other issues that made it difficult to find the raspberry pi's ip address (which I would rather ssh to) and may have contributed to the connectivity issues. This includes that ipconfig shows that the port which the raspberry pi is connected to is disconnected


You may wanna read this Raspberry Pi Zero W Headless setup – Windows 10 RNDIS Driver issue resolved tutorial and pay attention in the section on RNDIS Driver from MOD (Musical Operating Devices). Most Rpi0/W installation on a Windows OS 9particularly v10) runs into some sort of problem and can be simply resolved with the RNDIS Driver from MOD (Musical Operating Devices). I hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.