2

I'm trying to login to my Raspberry Pi Zero W via SSH over USB, as in this article https://desertbot.io/blog/ssh-into-pi-zero-over-usb and this one https://www.thepolyglotdeveloper.com/20 ... cable-ssh/. Explicitly, I've:

  • Flashed the image to my SD card (I'm using the November 2018 Raspbian Stretch Lite image. I've also tried using a Raspbian Jessie image as per the articles.)
  • Created an empty file called ssh in the boot directory
  • Added dtoverlay=dwc2 to the bottom of the config.txt file in the boot directory
  • Added modules-load=dwc2,g_ether directly after rootwait in the cmdline.txt file in the boot directory

I've plugged a HDMI cable into the Pi and it's booting correctly to the login prompt. However, if I try and ping raspberrypi.local from my Macbook, I get no response (the exact message is "ping: cannot resolve raspberrypi.local: Unknown host"). Trying to SSH in fails as well (it just hangs). Intuitively, I feel this is a host name resolution problem on my Macbook's side, but I can't figure out how to fix it.

Having googled MacOS .local resolution problems, a commonly found issue is that these addresses are only resolved if some form of sharing has been enabled (for instance, file sharing). I've tried enabling this and it has not resolved my problem.

Has anyone else experienced this? Any help would be very much appreciated!

Full disclaimer, this is a xpost from the Raspberry Pi forums.

  • Does your RasPi has an ip address? Look at it with ip addr. – Ingo Apr 8 at 8:10
  • does this answer point you in a direction raspberrypi.stackexchange.com/a/96733/90251 <- maybe the bonjour service is not started on you mac? – eli Apr 20 at 12:25
0

I had the same problem and found the solution here:

In Linux go to the network connections editor and in the "IPv4 Settings" tab, set Method: to "Link-Local Only". This was the only setting that let me do ssh pi@rasberrypi.local. Once I was on the Pi Zero console, I could access the internet.

I am not sure if Mac has the same options as Linux, but this worked for me.

  • On my Raspberry Pi I enter network connections editor and get the error message: -bash: network: command not found. What tab do you mean? – Ingo Sep 6 at 9:08
  • The network connections editor is on the computer that is trying to ssh into the pi – GammaGames Sep 6 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.