1

I did headless setup of the Pi 3B+ and what I've done was:

  1. Flashed the last OS on the SD card (Raspbian Stretch full 2018-11-13)
  2. Created two files in the root directory of the SD card:

    • wpa_supplicant.conf with the contents I will show below
    • ssh (empty)

After that my Pi successfully connected to my WiFi network and I was able to SSH into it.

However when I tried to look into /etc/wpa_supplicant/wpa_supplicant.conf which supposed to contain network information - it was empty.

I looked into the file with

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

I remember that last time I did that thing with RPi 3B (not plus) this file contained my networks.

Does anybody have an ideo why I see this file empty?

My wpa_supplicant.conf file is the following:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=RU

network={
    ssid="myWiFiname"
    psk="myWifipass"
    key_mgmt=WPA-PSK
}

All spaces I replaced for TABs. Bythe way: is it really necessary?

1

The problem was in the .wpa_supplicant.conf.swp hidden file stored in the same directory.

As I removed this file, everything worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.