I'm trying to setup WiFi on my RaspberryPi running Raspbian. WPI_GUI refuses to allow my to save it's configuration as

The configuration could not be saved. The update_config=1 configuration option must be used for configuration saving to be permitted

This is strange, as the contents of my /etc/wpa_supplicant/wpa_supplicant.conf contain:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


2 Answers 2



sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

and add the line


below each


line. Save the file and reboot, I had a similar problem (could not edit bad settings) and it allowed me to edit the settings again after the reboot.

In my case though the problem was an incorrectly configured wireless, it seemed to get stuck in a dead loop of trying to connect and would not let me use the GUI to correct the problem!

  • Hah nice one! :D
    – Alexander
    May 15, 2013 at 14:43

I got a similar message recently. For me I had to add


to the top of the wpa_supplicant.conf file. Got a write error warning once but new Wifi configurations now save properly.

  • But this is set by default so normally there is no need to set it.
    – Ingo
    Dec 18, 2019 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.