1

I am a newbie and perhaps this issue is incorrect. I am going to connect raspberry (3B+) with the laptop, then connect it via OpenSSH (OS is Windows, + WSL) or VNC. I am using mobile internet.

About 2 weeks ago I could have an access to raspberry pi shell. But I had apt-get update error. I read similar issue, where it was recommended to reboot the OS Raspbian and try again. I tried it several times, but it doesn't help. I used as balenaEtcher, and win32diskimager too.

Host name was 'raspberrypi.local', it worked. Now I tried also 'raspberrypi', 'raspberrypi.mshome.net' and several IP addresses.

A little change in my issue: I had an access to raspberry session, but it's inactive. It is appeared window, where shows: 'WARNING POTENTIAL SECURITY BREACH THe server's host key does not match the one putty has cached in the registry. This means that either the server administartor has changed the host key, or you have actually connected to another computer pretending to be the server. The new ssh key fingerprint is:................. ..............(I suppose, there has written ipv6 address) If you were expecting this change and trust the new key, hit yes to update Putty`s cache and continue connecting. If you want to carry on connecting but without updating the cache, hit No. If you want to abandon the connection completely, hit Cancel'

  • What do you mean by "mobile internet"? Are you (your PC/laptop) from which you are connecting to the raspberry pi over the SSH, in the same network? – Duck Dodgers Aug 5 at 8:27
  • @DuckDodgers, Thank you for reply! Really I do not know. I am sharing internet of mobile phone for laptop. Ethernet cable is used for connection with raspberry, so I am using mobile internet. Please, let me know if i am doing something wrong. – Dias-77 Aug 5 at 23:40
  • @Dmitry Grigoryev, Thank you for edit! – Dias-77 Aug 5 at 23:41
0

You might need to specify some more details, but I suggest the following:

  • First you need to make sure that you are connected to the same network. I'm assuming that by "Mobile internet" you are refering to WiFi. Connect to the same network.

  • Open your Windows terminal and type ipconfig to see the IP Address of both your laptop and your Access Point (WiFi Router).

  • Since .local is not working, you might want to check if your RPi is actually connected to the network. Go to your browser and type the IP address of your router. The layout depends on your provider, but it will show you the devices that are connected to the network. Here, you can see if your RPi is online.

  • If it is online, try to scan your local network by setting a range of IP addrresses (For example, 192.168.0.0 - 192.168.0.255) to idenfity the IP address of your RPi. I use the https://angryip.org/download/#windows for windows.

  • Get your specific IP Address and connect using Putty, or SSH the terminal, as you did before.

  • If your RPi is not online, you'll have to use a cable instead of a wireless.

  • Thank you for reply! I forgot to write about it. Raspberry pi is connected via Ethernet cable and HDMI cable ( I have no display), and the internet from mobile data. Laptop is having Internet from Ethernet, I disconnect for raspberry pi, so I am sharing internet from smartphone)) – Dias-77 Aug 5 at 23:52
  • I tried it. angry ip did not show raspberry's ip address. – Dias-77 Aug 6 at 0:41
0

Everyone thank you so much! I do not know how it is solved, i changed a lot of things, also reset network settings and rebuilt again. And finally, i get connection to putty, did update! ping still does not work but i am able to use mobile internet/wifi now. Now i should to disconnect raspberry now, going to continue tomorrow. I hope nothing will be lost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.